Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 12-09-2013, 03:28 PM   #1
Newbie
 
Join Date: Dec 2013
Posts: 5
Rewards Points: 10
Question

Inducer Fan isnt coming on my Carrier 58DHB


Hello All,

I have a Carrier 58DHB gas furnace. I have been using this heater w/o a problem, then suddenly last week it stopped functioning correctly:

I turn it on and I hear the ignitor coming on and lighting a flame, but it doesn't go further than that. I hear a noise coming from the gas valve, then after a few attempts to ignite then this creaking noise starts. The inducer fan doesn't come on either. I don't know what to do.

I checked the board and it looks fine no burn marks or anything, I thought maybe the transformer, but when I removed it and pressed the main switch manually , the blower fan came on, so I believe the transformer is ok. I had an old unit like mine, and I replaced the inducer motor/fan, but still nothing, same thing.

Any suggestions or help would be greatly appreciated.

Thanks

Ron

NA80 is offline   Reply With Quote
Old 12-10-2013, 05:42 PM   #2
Member
 
Join Date: Sep 2010
Posts: 453
Rewards Points: 252
Default

Inducer Fan isnt coming on my Carrier 58DHB


2 simple checks:
1) check the rubber hose from pressure switch for fraying/cracks, especially near each end. If 'bad' carefully shorten hose with a razor, if possible, or replace as necessary.
2. remove hose and check for 'gunk' buildup on each device and clear with a pipe cleaner or paperclip if it's there.

diyorpay is offline   Reply With Quote
Old 12-11-2013, 02:08 AM   #3
Newbie
 
Join Date: Dec 2013
Posts: 5
Rewards Points: 10
Default

Inducer Fan isnt coming on my Carrier 58DHB


I pulled the hose out and it was fine and clear, I cleaned each end and still nothing. Any other suggestions? Do you guys thinks it's the gas valve since it's making that clicking noise?
NA80 is offline   Reply With Quote
Old 12-11-2013, 04:35 AM   #4
An old Tradesmen
 
Join Date: Oct 2008
Location: PA
Posts: 25,554
Rewards Points: 2,788
Default

Inducer Fan isnt coming on my Carrier 58DHB


It may be. Wiggle the connectors on it. Sometimes the connectors on the smart valves loose their seating.
__________________
When posting in certain forums, knowing your location will help others give better feedback/advice/solutions to your questions.
beenthere is offline   Reply With Quote
Old 12-11-2013, 07:09 AM   #5
Member
 
biggles's Avatar
 
Join Date: Jan 2008
Location: Long Island
Posts: 3,630
Rewards Points: 2,000
Default

Inducer Fan isnt coming on my Carrier 58DHB


the ID motor is the first item to run with a heat call from the stat... nothing follows without the pressure switch staying closed
biggles is offline   Reply With Quote
Old 12-11-2013, 10:17 PM   #6
Newbie
 
Join Date: Dec 2013
Posts: 5
Rewards Points: 10
Default

Inducer Fan isnt coming on my Carrier 58DHB


Checked the wires, they're okay.
The pressure sensor seems ok, I pressed the reset (on the sensor) and held it down. It stop making the igniting noise then I released it and it went back to igniting. I also bypassed the sensor and same thing (wired both orange wires together). I'm starting to think there is a problem inside the gas valve? What else can I do? This is becoming very aggravating. Any help would be much appreciated.
Attached Thumbnails
Inducer Fan isnt coming on my Carrier 58DHB-image.jpg  
NA80 is offline   Reply With Quote
Old 12-12-2013, 09:29 AM   #7
Hvac Pro
 
Join Date: Nov 2008
Location: Winnipeg, Canada
Posts: 9,621
Rewards Points: 2,380
Default

Inducer Fan isnt coming on my Carrier 58DHB


If it were my furnace I would replace it. It is over 20-25 yrs old. It has 2 circuit boards. One behind the pressure switch for the inducer fan and the other in the fan compartment. It is a VERY difficult furnace to troubleshoot as there is no service manual with a clear description of what those boards do and the sequence of operation. I read some old info and apparently it uses some wheatstone bridge electronic circuitry with the 2 boards, gas valve, igniter in sequence which is very difficult to understand unless you do electronics. Techs who understand it are very old school and rare as hens teeth as that unit is obsolete. I can easily troubleshoot 95-98% of the furnaces out there but that one falls in the 2% category that I don't know. I replace them as the cost of repairs is prohibitive to my customers if you have to replace both boards . When one fails it can damage the other. Going to be very difficult to find someone who knows that unit. Sorry.
__________________
"Cut it twice and it is still too short".

Last edited by yuri; 12-12-2013 at 10:02 AM.
yuri is online now   Reply With Quote
Old 12-12-2013, 04:30 PM   #8
Newbie
 
Join Date: Dec 2013
Posts: 5
Rewards Points: 10
Default

Inducer Fan isnt coming on my Carrier 58DHB


Thanks!

Anyone else w/ any other suggestions?
NA80 is offline   Reply With Quote
Old 12-13-2013, 10:28 PM   #9
Member
 
Join Date: Oct 2012
Posts: 277
Rewards Points: 256
Default

Inducer Fan isnt coming on my Carrier 58DHB


Quote:
Originally Posted by NA80 View Post
Hello All,

I have a Carrier 58DHB gas furnace.

I turn it on and I hear the ignitor coming on and lighting a flame, but it doesn't go further than that. I hear a noise coming from the gas valve, then after a few attempts to ignite then this creaking noise starts. The inducer fan doesn't come on either. I don't know what to do.

I replaced the inducer motor/fan, but still nothing, same thing.

Any suggestions or help would be greatly appreciated.

Thanks

Ron
If the inducer fan doesn't run nothing else should be happening!

You should not be getting an ignition sequence.

Something is definately wrong and wrong in a way that is potentially very dangerous. Call a qualified Carrier dealer and have them send over a service tech.
old_squid is offline   Reply With Quote
Old 12-15-2013, 10:54 AM   #10
Newbie
 
Join Date: Dec 2013
Posts: 5
Rewards Points: 10
Default

Inducer Fan isnt coming on my Carrier 58DHB


Update: so after further testing and analysis, I replaced the inducer motor circuit bored, and magically the inducer fan started, and went though process smoothly. I knew this was an excellent furnace and I didn't want to part ways w it yet. Thank god I didn't need a tech, they probably woulda wasted my time, nor was this that sevre of an issue. I think now I should go into the HVAC business .
Thanks everyone!
NA80 is offline   Reply With Quote
Old 12-15-2013, 11:25 AM   #11
Hvac Pro
 
Join Date: Nov 2008
Location: Winnipeg, Canada
Posts: 9,621
Rewards Points: 2,380
Default

Inducer Fan isnt coming on my Carrier 58DHB


It was a good reliable furnace and the first generation of mid efficiency furnaces. Problem begins when you have to pay a service company for repairs and they are expensive time consuming repairs which most people won't tolerate or want at that age. Glad you got it going.

__________________
"Cut it twice and it is still too short".

Last edited by yuri; 12-15-2013 at 11:46 AM.
yuri is online now   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help: Sewage smell coming from shower drain! erikerikerik Plumbing 23 01-11-2014 02:09 AM
Carrier - Blower fan NOT coming on anku HVAC 8 08-30-2013 08:46 AM
Carrier 9200 Weathermaker furnace leaking Feathergreen HVAC 5 04-02-2013 04:41 PM
Goodman GMNT 080-4 inducer problem RiccH HVAC 18 03-26-2011 03:47 AM
New pressure switch and inducer and still incorrect drafting kevintabb HVAC 5 01-19-2010 12:59 PM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.