Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 12-21-2009, 04:57 PM   #1
Newbie
 
Join Date: Dec 2009
Posts: 12
Share |
Default

Ignitor sparks through complete cycle. Carrier 58GS


I'm having a hard time determining why my ignitor is sparking thoughout the complete heating cycle. Hoping someone can help.

My furnace is a Carrier 58gs model. Here's a scan of it's wiring diagram....




If you look at the gas valve in the diagram, there's a hold switch between terminals 4 & 5 on the gas valve. Apparently this connection is held until the main gas burners come on. Well, I constantly have 24v to terminal 5 instead of it shutting off after the main gas valve opens. I ended up replacing the gas valve assembly and the new one is doing the exact same thing! Am I missing something here?

I've also replaced the 3-wire pilot assembly, and it's working as it should.

slick-rides is offline   Reply With Quote
Old 12-21-2009, 06:57 PM   #2
Newbie
 
Join Date: Mar 2009
Posts: 21
Default

Ignitor sparks through complete cycle. Carrier 58GS


Ya but is the little sensor neww/the orange wire going to it.Pick and hold coil in that valve...clean or replace little square porcelin sensor

hf05 is offline   Reply With Quote
Old 12-21-2009, 07:11 PM   #3
Newbie
 
Join Date: Dec 2009
Posts: 12
Default

Ignitor sparks through complete cycle. Carrier 58GS


Which sensor are you asking about?

This gas valve doesn't have a pick and hold coil. Instead it uses a pressure switch. Once the heat sensor from the pilot turns on the main gas valve, the pressure from the main gas flow is supposed to open the switch.
slick-rides is offline   Reply With Quote
Old 12-21-2009, 09:32 PM   #4
Newbie
 
Join Date: Mar 2009
Posts: 21
Default

Ignitor sparks through complete cycle. Carrier 58GS


3 wire pilot. grenn,yellow and white?.if so u have a spark electrode and if u changed this u would know what i mean !
hf05 is offline   Reply With Quote
Old 12-21-2009, 10:48 PM   #5
Newbie
 
Join Date: Dec 2009
Posts: 12
Default

Ignitor sparks through complete cycle. Carrier 58GS


So you're saying the spark electrode itself has a sensor in it? That doesn't seem right. I removed the electrode from the old pilot and transfered it to the new since it was sparking fine.
slick-rides is offline   Reply With Quote
Old 12-21-2009, 11:47 PM   #6
Newbie
 
Join Date: Mar 2009
Posts: 21
Default

Ignitor sparks through complete cycle. Carrier 58GS


they yanked response...
hf05 is offline   Reply With Quote
Old 12-22-2009, 05:57 PM   #7
HVAC Tech/ Browns Fan
 
Join Date: Dec 2009
Location: Dayton, ohio
Posts: 541
Default

Ignitor sparks through complete cycle. Carrier 58GS


Ok is the pilot a long metal ( bi Metal) It has yellow, green and white wire going to it. If so you need to clean the inside metal were the flame hit it. You should not need to replace it just clean it. Please if anything take a pic of it ( pilot)

Last edited by Tator1076; 12-22-2009 at 06:16 PM.
Tator1076 is offline   Reply With Quote
Old 12-22-2009, 06:28 PM   #8
Newbie
 
Join Date: Dec 2009
Posts: 12
Default

Ignitor sparks through complete cycle. Carrier 58GS


Quote:
Originally Posted by Tator1076 View Post
Ok is the pilot a long metal ( bi Metal) It has yellow, green and white wire going to it. If so you need to clean the inside metal were the flame hit it. You should not need to replace it just clean it. Please if anything take a pic of it ( pilot)

Yes, it's the 3-wire(G,W,Y) pilot. I've already replaced it because it wasn't working before. I even tested the circuit with jumpers to make sure the pilot wasn't my problem. I did this by disconnecting the 3 wire plug coming from the pilot. I then jumpered what would be the green and yellow wire terminals, pilot and igniter comes on. I then moved the jumper to the white and yellow and the main gas burner comes on, but the igniter continues to spark.

If I disconnect the wire from terminal 5 on the gas valve, the ignitor stops. I have a constant 27v at terminal 5, when it should be switched off.

If you need any more info or want me to check something else, let me know.
slick-rides is offline   Reply With Quote
Old 12-22-2009, 06:43 PM   #9
Newbie
 
Join Date: Dec 2009
Posts: 12
Default

Ignitor sparks through complete cycle. Carrier 58GS


Ignitor is part # LH680005 and gas valve is part # EF32CW183.





slick-rides is offline   Reply With Quote
Old 12-22-2009, 06:46 PM   #10
HVAC Tech/ Browns Fan
 
Join Date: Dec 2009
Location: Dayton, ohio
Posts: 541
Default

Ignitor sparks through complete cycle. Carrier 58GS


Ok check and see if the pilot is rolling. If it is you may have a crack near that piloit when the fan hits it.
Tator1076 is offline   Reply With Quote
Old 12-22-2009, 06:48 PM   #11
HVAC Tech/ Browns Fan
 
Join Date: Dec 2009
Location: Dayton, ohio
Posts: 541
Default

Ignitor sparks through complete cycle. Carrier 58GS


Note you may check the pig tail in sure its has a good conection together. You can do it when heat is calling
Tator1076 is offline   Reply With Quote
Old 12-22-2009, 06:52 PM   #12
Newbie
 
Join Date: Dec 2009
Posts: 12
Default

Ignitor sparks through complete cycle. Carrier 58GS


Looks fine to me. I just tried to take a couple pics and a short video. Give me a minute and I'll post them up.
slick-rides is offline   Reply With Quote
Old 12-22-2009, 06:56 PM   #13
HVAC Tech/ Browns Fan
 
Join Date: Dec 2009
Location: Dayton, ohio
Posts: 541
Default

Ignitor sparks through complete cycle. Carrier 58GS


Quote:
Originally Posted by slick-rides View Post
Looks fine to me. I just tried to take a couple pics and a short video. Give me a minute and I'll post them up.

gave me a pic of pressure switch too
Tator1076 is offline   Reply With Quote
Old 12-22-2009, 07:01 PM   #14
Newbie
 
Join Date: Dec 2009
Posts: 12
Default

Ignitor sparks through complete cycle. Carrier 58GS


Pressure switch is inside the main gas valve as pictured above. The switch is between terminals 4 & 5, with 5 being the one going to the ignitor.

Video will be on youtube in 2 min.



slick-rides is offline   Reply With Quote
Old 12-22-2009, 07:02 PM   #15
MXer
 
3 legged dog's Avatar
 
Join Date: Dec 2009
Location: South West Coast
Posts: 128
Default

Ignitor sparks through complete cycle. Carrier 58GS


Sounds like something wrong with spark electrode.
Could also be a bad ground.

3 legged dog is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off





Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.