Ice Inside And Outside - HVAC - DIY Chatroom Home Improvement Forum


Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Display Modes
Old 06-26-2009, 05:09 PM   #1
Newbie
 
Join Date: Jun 2009
Posts: 2
Rewards Points: 10
Default

ice inside and outside


How is everyone doing today?
So i came home today to find my house at 84F. The air blowing out of my vents was not ice cold like it normally is so i went out side to check the unit and i found ice all over. i turned off the unit and went into the attic to check the other part of the unit......yup i found ice.

i live in houston texas and it has been hot here. i mean very hot. 100-103F with 90-100% humidty and a heat index of 106-110F

This is the first time i have ever seen ice form. Last year's check up showed everything working great. System was built in 1996

Is this an issue? Something i need to get someone out ASAP? If it is bad what could be causing it?

you guys helped in the past and hope you can help again. I like knowing what to except before a guy come out or even if a hvac guy needs to come out.





Advertisement

firedog is offline   Reply With Quote
Old 06-26-2009, 05:12 PM   #2
Newbie
 
Join Date: Jun 2009
Posts: 2
Rewards Points: 10
Default

ice inside and outside


let me add that the Filters were replaced 2 days ago. i have two returns a 20x25 and a 12x12. both have a 3m filter in it. same type i have been using for a over a year

Advertisement

firedog is offline   Reply With Quote
Old 06-26-2009, 06:27 PM   #3
Member
 
HvacWiz's Avatar
 
Join Date: Nov 2006
Location: Northwest Ohio
Posts: 286
Rewards Points: 250
Default

ice inside and outside


Unit is probaly low on charge.
HvacWiz is offline   Reply With Quote
Old 06-26-2009, 07:32 PM   #4
Member
 
biggles's Avatar
 
Join Date: Jan 2008
Location: Long Island
Posts: 3,630
Rewards Points: 2,000
Default

ice inside and outside


run the unit supply fan only off stat no cooling only all night,and it will all melt away.check it tomorrow morning the ice always starts at the air handler after 30 minutes or so.squirrel cage rounds are clean???and the filter sounds good.see if it cools the house down somewhat before you notice the ice out of the evap line in the attic keep the panels on just check the insulated line there.with the unit in fan only verify you have the standard air you have always had out of the registers..sheet of news paper over the return grill see if it holds it up one return at a time...that ice at the copressor isn't bad if it was 100% covered you might of lost a valve with the liquid flooding back into that suction that has the ice on it.could be just short enough to cause ice did you ever see this before?concentrate on the air side of the attic unit either the air isn't going out or the return is restricting causing a low air situation and making it like a refrigerator with the ice build up.have you ever had gas added in the past?
biggles is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off





Top of Page | View New Posts