Hot Surface Igniter And Gas Valve Not Always Working During Call For Heat - HVAC - DIY Chatroom Home Improvement Forum


Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Display Modes
Old 12-09-2012, 10:54 AM   #1
Newbie
 
Join Date: Dec 2012
Posts: 3
Rewards Points: 10
Default

Hot surface igniter and gas valve not always working during call for heat


Hi Guys/Girls
I have a Rheem Criterion II Model RCBA-3765GG17 from 1995.

I'm new to HVAC and have watched many YouTube videos in the past days and have been able to eliminate many points of failure


I have been working on it for 4 days now and believe I need to replace the control board. I have also been working with a buddy of mine over the phone that is a HVAC Tech, but has left for a hunting trip. He will not return for a couple of more days and cold weather is supposed to be moving in.

During the call for heat, the two green LEDs illuminate and the IDM runs and the blower starts about 10 secs later.

The issue seems to be with the control of Honeywell VR8205H 8016 gas valve and the hot surface igniter. They work, just are not always activated, which I assume is the fault of the control board.

Limits are closed and are getting 26VAC and pressure switch is working correctly. (tested 0 volts across terminals when motor is on) The hot surface ignitor ohms out at 175 which is within its limit.

The igniter does not always heat up (actually very rarely) nor does the gas valve open, although the fan will run almost continuous (30 mins or more)

In the event the igniter does heat up, the gas valve will follow suit and open (This is a strange behavior and why I think the control board needs replaced) Let me explain.

The gas valve should open for about 4 secs whether the hot surface igniter heats up or not but it does not, and when it does open, it is only after the igniter has heated up. It's just strange that they both work and don't work at the same time leading me to believe it is the control board failing to control them correctly.

When these two are working correctly and the burner fires up, it will run until call for heat ends. The gas turns off, but the IDM and blower will run continuously once again as before and thus the igniter and gas valve will fail to start when call for heat is cycled again.

Should note that a power cycle does not resolve this either. To be honest I'm not sure what causes the gas valve and the igniter to start working but it's awesome when it does, but provides me no clues to why it decides to start working properly.

Any advice?

Thanks in advance
Mike

Advertisement

Modify_inc is offline   Reply With Quote
Old 12-09-2012, 11:56 AM   #2
Hvac Pro
 
Join Date: Nov 2008
Location: Winnipeg, Canada
Posts: 10,137
Rewards Points: 912
Default

Hot surface igniter and gas valve not always working during call for heat


The circuit board is 17 yrs old and that is about as long as they last. Something is going wrong with the timing circuit of it. The valve does not necessarily need to open for 4 secs w/o the igniter as each component has it's own seperate relay. The board is not actuating them at the proper time and needs changing. Americanhvacparts.com seems like a good site.

Advertisement

__________________
"Cut it twice and it is still too short".
yuri is offline   Reply With Quote
Old 12-09-2012, 12:40 PM   #3
Roofmaster
 
Join Date: Oct 2012
Location: Maryland
Posts: 3,669
Rewards Points: 2,096
Default

Hot surface igniter and gas valve not always working during call for heat


Control Board. Pex Supply. Free overnight in most cases.
jagans is offline   Reply With Quote
Old 12-09-2012, 02:53 PM   #4
An old Tradesmen
 
Join Date: Oct 2008
Location: PA
Posts: 26,573
Rewards Points: 4,784
Default

Hot surface igniter and gas valve not always working during call for heat


Or it could be the pressure switch not always closing.
beenthere is offline   Reply With Quote
Old 12-10-2012, 08:52 AM   #5
Newbie
 
Join Date: Dec 2012
Posts: 3
Rewards Points: 10
Default

Hot surface igniter and gas valve not always working during call for heat


Quote:
Originally Posted by beenthere View Post
Or it could be the pressure switch not always closing.
I checked it though, and I can hear it close when it comes on and open when the unit turns off. It's zero volts when testing while the motor is running which I understand is ideal. I tested it again, jumping the terminals and the unit shut off-- The fuse blew at the transformer. I'm currently looking for a replacement fuse.
Modify_inc is offline   Reply With Quote
Old 12-10-2012, 10:04 AM   #6
Member
 
hvaclover's Avatar
 
Join Date: Oct 2008
Location: Suburbs of Detroit Mi
Posts: 3,704
Rewards Points: 2,000
Default

Hot surface igniter and gas valve not always working during call for heat


should be a 3 or 5 amp automotive style fuse ( ATO style fuse is the official designation).

Any auto parts store has them.
__________________
Just slow, not stupid.
hvaclover is offline   Reply With Quote
Old 12-10-2012, 12:40 PM   #7
Newbie
 
Join Date: Dec 2012
Posts: 3
Rewards Points: 10
Default

Hot surface igniter and gas valve not always working during call for heat


Quote:
Originally Posted by hvaclover View Post
should be a 3 or 5 amp automotive style fuse ( ATO style fuse is the official designation).

Any auto parts store has them.
HA, I wish, maybe back in the day
I have spent half a day looking for that fuse and no one has it.

Littlefuses,the maker of the fuse, wants me to order a quantity of 50.

Every where I called, they acted as if they had it, but when getting their they realized they didn't have one that small.

It is a 229 2AG rated at 2A @ 250V. It is a little glass fuse wired in-line from the transformer.

At worst I assume I could just change the whole wire out and use a standard length fuse with the same rating correct?

The length is .56" an the diameter is .177"
Here is a pic:
Attached Images
 

Last edited by Modify_inc; 12-10-2012 at 12:41 PM. Reason: actually 2 Amp
Modify_inc is offline   Reply With Quote
Old 12-10-2012, 01:55 PM   #8
Member
 
Join Date: Oct 2009
Location: Nebraska
Posts: 2,362
Rewards Points: 1,000
Default

Hot surface igniter and gas valve not always working during call for heat


Spend 10 bucks on a new transformer and put an external fuse on it
Marty S. is offline   Reply With Quote
Old 12-10-2012, 02:23 PM   #9
Roofmaster
 
Join Date: Oct 2012
Location: Maryland
Posts: 3,669
Rewards Points: 2,096
Default

Hot surface igniter and gas valve not always working during call for heat


Radio Shack did not have this?

You can also get an auto fuze holder at wallmart and use an auto type fuze. I cant even see if that glass type is blown or not, the damn wire is so thin

Sounds like you spent more than a new board on Gas running around looking for the fuse, and it did not blow for nothing. Had you ordered the new board from Pex Supply you would have it in hand this afternoon, and installed in half an hour, and old man winter is coming in tonight.

If that board is 17 years old its probably shot.

Last edited by jagans; 12-10-2012 at 02:28 PM.
jagans is offline   Reply With Quote
Old 12-10-2012, 04:46 PM   #10
Member
 
newtech's Avatar
 
Join Date: Mar 2009
Posts: 251
Rewards Points: 162
Default

Hot surface igniter and gas valve not always working during call for heat


Quote:
Originally Posted by Modify_inc View Post
HA, I wish, maybe back in the day
I have spent half a day looking for that fuse and no one has it.

Littlefuses,the maker of the fuse, wants me to order a quantity of 50.

Every where I called, they acted as if they had it, but when getting their they realized they didn't have one that small.

It is a 229 2AG rated at 2A @ 250V. It is a little glass fuse wired in-line from the transformer.

At worst I assume I could just change the whole wire out and use a standard length fuse with the same rating correct?

The length is .56" an the diameter is .177"


Here is a pic:
For sng. If you have any outside x-mas lights, many times they will give you extra fuses with them. One may just work...
newtech is offline   Reply With Quote
Old 12-10-2012, 05:20 PM   #11
An old Tradesmen
 
Join Date: Oct 2008
Location: PA
Posts: 26,573
Rewards Points: 4,784
Default

Hot surface igniter and gas valve not always working during call for heat


Quote:
Originally Posted by Modify_inc View Post
I checked it though, and I can hear it close when it comes on and open when the unit turns off. It's zero volts when testing while the motor is running which I understand is ideal. I tested it again, jumping the terminals and the unit shut off-- The fuse blew at the transformer. I'm currently looking for a replacement fuse.
jumping out the pressure switch shouldn't blow the fuse. unless you grounded it out somehow.

Those fuses are sold in auto stores. I get mine there every so often.
beenthere is offline   Reply With Quote
The Following User Says Thank You to beenthere For This Useful Post:
ben's plumbing (12-10-2012)
Old 12-10-2012, 06:12 PM   #12
Hvac Pro
 
Join Date: Nov 2008
Location: Winnipeg, Canada
Posts: 10,137
Rewards Points: 912
Default

Hot surface igniter and gas valve not always working during call for heat


It is a very odd glass fuse 1/2 the length of the regular ones and I suspect you have to get it from Rheem. I blew one yrs ago and luckily had a spare. I would chop it out an splice in a regular 3 amp GM purple auto fuse and use 2 stakon push connectors on it and wrap it in electrical tape. I do it all the time for jobs that have no fuses. Or you can buy a new inline fuse holder from Radio Shack if they have them.
__________________
"Cut it twice and it is still too short".
yuri is offline   Reply With Quote
Old 12-10-2012, 06:46 PM   #13
Part of the Clover Leaf
 
Join Date: May 2011
Location: NW Burbs of Detroit Mi.
Posts: 1,107
Rewards Points: 500
Default

Hot surface igniter and gas valve not always working during call for heat


Replacing with a mini breaker or a diff style fuse is a good idea. This one is a surprise to me....never saw a Rheem with that style of fuse....saw some vintage Honeywell control boards with glass fuses , but never a Rheem.

Just goes to show 'ya.....nobody knows everything in this biz.

Advertisement

hvac5646 is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off





Top of Page | View New Posts