DIY Chatroom Home Improvement Forum

DIY Chatroom Home Improvement Forum (http://www.diychatroom.com/)
-   HVAC (http://www.diychatroom.com/f17/)
-   -   Honeywell T8011R1006 Programmable Digital Thermostat-No Display (http://www.diychatroom.com/f17/honeywell-t8011r1006-programmable-digital-thermostat-no-display-154810/)

wperea 08-25-2012 12:27 PM

Honeywell T8011R1006 Programmable Digital Thermostat-No Display
 
Honeywell Model t8011r thermostat no display. Power went out a couple of days ago, I reset the breaker and the display came back on but each time I set the time it would reset. I removed the thermostat to see if there was a fuse. After I realized there was no fuse I put back the thermostat and now there is no display at all. Unit is coming on. Any ideas? Thank you in advance.

beenthere 08-25-2012 01:21 PM

Probably had a surge when the power went out or came back on. Good chance its time for a new stat.

wperea 09-06-2012 05:34 PM

Quote:

Originally Posted by wperea (Post 996064)
Honeywell Model t8011r thermostat no display. Power went out a couple of days ago, I reset the breaker and the display came back on but each time I set the time it would reset. I removed the thermostat to see if there was a fuse. After I realized there was no fuse I put back the thermostat and now there is no display at all. Unit is coming on. Any ideas? Thank you in advance.

So I replaced the stat and the 5amp fuse in the air handler and still no digital display. Fan comes on and the a/c comes on. Unfortunately I still cannot see the temperture setting. Any other suggetions?

beenthere 09-06-2012 06:00 PM

Brand and model number of new thermostat.

wperea 09-06-2012 06:06 PM

Quote:

Originally Posted by wperea (Post 1004568)
So I replaced the stat and the 5amp fuse in the air handler and still no digital display. Fan comes on and the a/c comes on. Unfortunately I still cannot see the temperture setting. Any other suggetions?

Same Brand & Model.

beenthere 09-06-2012 06:16 PM

The 8011 wasn't a real popular model, which is partially why its a discontinued model. Since its working the A/C and heat. Take that one back, and get a different model.

A loose connection at the furnace could cause it not to work, but generally never caused them to work without a display.

wperea 09-06-2012 06:26 PM

Quote:

Originally Posted by wperea (Post 1004591)
Same Brand & Model.

Guess what beenthere? It has been nearly an hour since I replace the stat and it literally just came on and the display is working. YOU ARE AWESOME! I can't thank you enough.:thumbup:

beenthere 09-06-2012 06:30 PM

Wish i had actually helped you.

That model stat, ws one I used for a while when it first came out. It was a cost effective stat. But had a fair number that died in just a year or 2. Hope yours last a good long time.

wperea 09-06-2012 06:41 PM

Quote:

Originally Posted by wperea (Post 1004606)
Guess what beenthere? It has been nearly an hour since I replace the stat and it literally just came on and the display is working. YOU ARE AWESOME! I can't thank you enough.:thumbup:

You did. Your first answer was spot on.

beenthere 09-06-2012 07:45 PM

Thank you.

Just because your stat, A/C, and heat is working. Doesn't mean you can't hang around. We also have a general and an off topic forum. For all kinds of conversations, along with many other forums you may find usefull.

Doc Holliday 09-06-2012 07:52 PM

Get a room. LOL!!!!!! :laughing:

beenthere 09-06-2012 07:56 PM

Quote:

Originally Posted by Doc Holliday (Post 1004667)
Get a room. LOL!!!!!! :laughing:

:laughing::laughing::laughing::laughing::laughing:


All times are GMT -5. The time now is 08:58 AM.


Copyright 2003-2014 Escalate Media LP. All Rights Reserved