Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 10-28-2011, 01:18 AM   #1
Newbie
 
Join Date: Oct 2011
Posts: 1
Rewards Points: 10
Default

Honeywell s8910U Hot surface ignition


My 15 year old Rheem furnace will not light. The LED on the Honeywell ignition box does not light. The thermostat is sending a signal to the unit. Any suggestions?

tonymichon is offline   Reply With Quote
Old 10-28-2011, 03:25 PM   #2
Member
 
Join Date: Sep 2010
Posts: 453
Rewards Points: 252
Default

Honeywell s8910U Hot surface ignition


Start with Heating Troubleshooting Flow Chart, about halfway down the page.

http://www.arnoldservice.com/Trouble...g_Problems.htm

diyorpay is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Honeywell TrueSteam wont work! Stewart Daniel General DIY Discussions 18 12-20-2010 07:41 AM
REZNOR gas shop heater WHOOMP ! on ignition Wildcat355 HVAC 14 01-29-2010 05:57 PM
Honeywell Oil Ignition Control garpox HVAC 4 12-30-2009 07:40 PM
This may help someone with carrier ignition problems AweMan HVAC 15 02-09-2009 01:20 PM
Hot surface ignitor problems hateheater HVAC 2 01-30-2008 06:26 PM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.