Heil T-stat Issue - HVAC - DIY Chatroom Home Improvement Forum


Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Display Modes
Old 10-24-2008, 02:15 AM   #1
Newbie
 
Join Date: Oct 2008
Posts: 3
Rewards Points: 10
Default

heil t-stat issue


Hey great site. I have a heil ultimate III furnace in my house I bought 8 Months ago. When i moved in I put in a Noma digital 5+2 tstat, works great. Last week got a noma digital 7 day tstat, hooked it up and the furnace just cycles the draft motor on and off in about 15 sec intervals. I took it back got a new one, same thing. The old one still works fine. I am an automotive tech so I started trying to figure out what was happening. An ohm meter shows both tstat's the same. accidently (sort of) I grabbed the two wires (one in each hand) and the furnace did the cycle thing. The 7 day works fine when calling for heat, but acts up when off. Any ideas? Thanks in advance

Advertisement

toymech is offline   Reply With Quote
Old 10-24-2008, 05:13 PM   #2
Member
 
hvaclover's Avatar
 
Join Date: Oct 2008
Location: Suburbs of Detroit Mi
Posts: 3,704
Rewards Points: 2,000
Default

heil t-stat issue


Bleeding voltage back.

Need an isolating relay.

Advertisement

__________________
Just slow, not stupid.
hvaclover is offline   Reply With Quote
Old 10-25-2008, 08:01 PM   #3
Newbie
 
Join Date: Oct 2008
Posts: 3
Rewards Points: 10
Default

heil t-stat issue


Hey Thanks. Got thinking about what you said and remember seeing an automoyive relay with a capacitor or resistor in it to stop arcing of the contacts. So I took the stat apart and sure enough there was a cap and resistor linking the two contacts together, so I cut the resistor. Works great now Thanks again
toymech is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cable issue or wiring issue? Duchey Electrical 57 12-15-2008 02:34 PM
heil? mhyman1302 HVAC 1 06-07-2008 09:26 AM
ritetemp programmable stat miked18 HVAC 9 12-17-2007 07:20 PM
Heating Issue! not mechanically inclined HVAC 3 11-09-2007 10:40 AM




Top of Page | View New Posts