DIY Chatroom Home Improvement Forum

DIY Chatroom Home Improvement Forum (http://www.diychatroom.com/)
-   HVAC (http://www.diychatroom.com/f17/)
-   -   Heil N8MPN Fail to Ignite (http://www.diychatroom.com/f17/heil-n8mpn-fail-ignite-120782/)

290627 10-21-2011 09:30 AM

Heil N8MPN Fail to Ignite
 
Good morning,

Long time reader, first time poster here. First want to thank you for all of the great advise we've found here in the past!

Currently we are having a bit of a conundrum with a Heil N8MPN propane furnace. When the heat is turned on the inducer motor starts and after a 15 second delay a relay fires, but the igniter does not light up. We've replace it with a known good igniter, so we know that it is not a bad igniter.

Searching has not turned up any related problems and fixes that we can find. Any idea on what might be wrong or what we should try next?

Thanks in advance!

290627 10-21-2011 01:02 PM

Probably should have given some more details, sorry.
  • Pressure switch is good/closing. 24v across it and to the board.
  • Limit switch is good/closing. 24v across it and to the board.
  • Rollout Switch is good/closing. 24v across it and to the board.
  • Fuse on board is good.

The black leading to the HSI is part of a duo plug on the board together with the inducer. The inducer side of the plug is getting 120v but the HSI side isnít getting anything.

Any ideas?

Patrick Eubanks 10-21-2011 01:24 PM

board
 
Sounds like a bad board.

Houston204 10-21-2011 07:27 PM

Does it display any trouble codes?

http://i151.photobucket.com/albums/s...4/ICPN8MPM.jpg


All times are GMT -5. The time now is 04:13 PM.