Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 01-26-2008, 07:08 AM   #1
Newbie
 
Join Date: Jan 2008
Posts: 2
Share |
Default

Heil ignition problem


I have a 1 year old Heil 90+ which is intermittently failing to fire. The first attemp the ignitor burns, the gas valve opens, the burners ignite and stay lit for 1 second then go out. The second attempt fires appropriately and stays lit and the entire cycle is complete. The furnace can work correctly for a couple of days and then the above problem occurs. Any idea what is causing this burner to go out at times? I've changed the flame sensor already and don't believe it is the thermostat. I do get a diagostic LED of 6 flashes (flame sense lost while running) when it is happening. Should I be concerned about leaving town for a couple of days?

Brickman is offline   Reply With Quote
Old 01-26-2008, 08:28 AM   #2
Union HVAC Tech.
 
Join Date: May 2007
Location: New Jersey
Posts: 607
Default

Heil ignition problem


Well if that's the code your getting, it's a flame sensor problem. Take a good look at the wire going to the sensor, is it damaged, insulation nicked anywhere? Are the crimped terminals tight? Ohm it out with a meter and see if it has any resistance, if so swap it out.

bigMikeB is offline   Reply With Quote
Old 01-26-2008, 03:31 PM   #3
Newbie
 
Join Date: Jan 2008
Posts: 2
Default

Heil ignition problem


The wire is fine (no apparant breaks or nicks) and fastened tightly. No resistance with Ohm meter. Note per prior message, the flame sensor was switched out 5 weeks ago and this did not fix the problem. The 6 flashes appears only when ignition lights and then goes out. After the next try, it stays lit and works fine with the LED flashing the usual soft heartbeat. Could it be the ignitor?
Brickman is offline   Reply With Quote
Old 01-26-2008, 05:24 PM   #4
Union HVAC Tech.
 
Join Date: May 2007
Location: New Jersey
Posts: 607
Default

Heil ignition problem


You can just time the igniter, a good one lights in less than 45 seconds from energizing.
bigMikeB is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Heil Furnace Burner Problem timothyr HVAC 79 02-12-2014 07:01 PM
This may help someone with carrier ignition problems AweMan HVAC 15 02-09-2009 01:20 PM
Heil problem with gas valve Frank4711 HVAC 1 12-14-2007 10:03 PM
Heil ignition problems sky jumper HVAC 1 11-16-2007 12:30 PM
HEIL 5000 Furnace Problem moore70 HVAC 5 03-26-2006 07:59 PM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.