Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 11-17-2010, 09:59 AM   #1
Newbie
 
Join Date: Nov 2010
Posts: 1
Share |
Smile

Heil Gas Pack Burner Issue




The above image is not my gas pack, but it is very similar.

My unit has worked great for about 12 years until just last week when it shut down via the flame roll out switch (#51 on the drawing). I pushed the manual reset button on the flame roll out switch and had my wife turn the heat on inside the house.

- The powered exhaust fan comes on.
- The pilot lights.
- The burners light.
- The blower motor comes on and warm air comes out of the registers.
- It runs for about 2 minutes and then goes out on the flame roll out switch again.

One thing I noticed was that there is a nice large blue flame at the end of each of the mixer tubes (#43 on the drawing) as it goes into the heat exchanger. But there is also a continous smaller flame between each of the mixer tubes completely across the outlet end right before it goes into the heat exchanger. Most of the heat from this smaller flame goes straight up and hits the bottome of the sheetmetal plate (#42) and then the roll out switch.

Does this sound normal for there to be a continuous small flame across the outlet end of the mixer tube assembly? There is a lot of rust in there and I am thinking it may have cracked or rusted through.

Also, I call part #43 mixer tubes, but I don't really know what the correct name for it is.

Thanks for any help. I just found this forum today and it seems to have a lot of good info from experienced folks.

Howard


Another Heil Gas Pack Similar to My Unit.


Another Heil Gas Pack Similar to My Unit.


Last edited by Howard99; 11-17-2010 at 10:13 AM.
Howard99 is offline   Reply With Quote
Old 11-17-2010, 08:12 PM   #2
HVAC / Plumbing
 
Join Date: Feb 2009
Posts: 1,801
Default

Heil Gas Pack Burner Issue


No there should not be a flame there. Make sure burner isn't stopped up

kenmac is offline   Reply With Quote
Old 11-17-2010, 08:20 PM   #3
Hvac Pro
 
Join Date: Nov 2008
Location: Winnipeg, Canada
Posts: 8,992
Default

Heil Gas Pack Burner Issue


Flame rollout scenarios:

Cracked heat exchanger
Heat exchanger plugged with rust (common in outdoor units) or soot
Gas valve faulty/overfiring

Recommend you get a skilled tech to find out why.
__________________
"Cut it twice and it is still too short".
yuri is offline   Reply With Quote
Old 11-18-2010, 04:53 AM   #4
An old Tradesmen
 
Join Date: Oct 2008
Location: PA
Posts: 24,489
Default

Heil Gas Pack Burner Issue


Quote:
Originally Posted by yuri View Post
Flame rollout scenarios:

Cracked heat exchanger
Heat exchanger plugged with rust (common in outdoor units) or soot
Gas valve faulty/overfiring

Recommend you get a skilled tech to find out why.
What Yuri said.
beenthere is offline   Reply With Quote
Old 12-04-2010, 05:40 AM   #5
Newbie
 
Join Date: Dec 2010
Posts: 5
Default

Heil Gas Pack Burner Issue


Hi guys, I have a gas pack (Heil) and it looks exactly like the picture with the burners at the top on first image of Howard99's post. Here is what mine is doing, what I've done and I cant think of what to do now!!!! The system began blowing cool air and just kept running while the temp in the house kept dropping. The only way to make the unit stop running was to pull the disconnect outside near the unit. When it was plugged back in both the large fan & the exhaust fan started up, but the pilot or the burners never lit. I replaced the valve (Honeywell) and nothing changed. Then I replaced the control board and still nothing changed. The thermostat seems to be working properly (it clicks when I turn it up) but nothing. If I switch the thermostat to off, both fans keep running. Even if my buddy disconnects the thermostat, they keep running. Through all this, I still have no heat, and no solution. Please respond if anyone has an idea. I will check this thread, and monitor my email. spearmad@gmail.com

Thanks, Dale
spearmad is offline   Reply With Quote
Old 12-04-2010, 05:56 AM   #6
An old Tradesmen
 
Join Date: Oct 2008
Location: PA
Posts: 24,489
Default

Heil Gas Pack Burner Issue


Did you check the roll out switches. You don't want ti to run if it has a cracked heat exchanger.
beenthere is offline   Reply With Quote
Old 12-04-2010, 06:02 AM   #7
Newbie
 
Join Date: Dec 2010
Posts: 5
Default

Heil Gas Pack Burner Issue


The flame roll out switch seems to have (2) wires and I haven't found any buttons on it. I will have my maintenance friend to check it for voltage today. I had a service tech check out the firebox about 2 months ago, and he said it looked god, no cracks, in his words, very good for a 10 year old gas pack. The continuous running of the fans has me and my "maintenance buddy" dumbfounded. Thanks for your reply, Dale
spearmad is offline   Reply With Quote
Old 12-04-2010, 06:08 AM   #8
An old Tradesmen
 
Join Date: Oct 2008
Location: PA
Posts: 24,489
Default

Heil Gas Pack Burner Issue


How often do you change your air filters?

Dirty air filters can cause the heat to cycle on high limit. And since its a safety control, and not an operating control. Its not designed to last long from opening and closing. And can fail opened. And will cause your problem.
beenthere is offline   Reply With Quote
Old 12-04-2010, 06:17 AM   #9
Hvac Pro
 
Join Date: Nov 2008
Location: Winnipeg, Canada
Posts: 8,992
Default

Heil Gas Pack Burner Issue


Yep. All manufacturers wire in the fan to run continuously when the high temp limit control opens. Needs to run to cool down the overheated heat exchanger and only when it resets will the fan stop. If it is stuck open then the fan won't stop.
__________________
"Cut it twice and it is still too short".
yuri is offline   Reply With Quote
Old 12-04-2010, 06:19 AM   #10
Newbie
 
Join Date: Dec 2010
Posts: 5
Default

Heil Gas Pack Burner Issue


Just changed them 2 weeks ago.
spearmad is offline   Reply With Quote
Old 12-04-2010, 06:24 AM   #11
An old Tradesmen
 
Join Date: Oct 2008
Location: PA
Posts: 24,489
Default

Heil Gas Pack Burner Issue


Quote:
Originally Posted by spearmad View Post
Just changed them 2 weeks ago.
And how long before then?
beenthere is offline   Reply With Quote
Old 12-04-2010, 06:27 AM   #12
Newbie
 
Join Date: Dec 2010
Posts: 5
Default

Heil Gas Pack Burner Issue


Thanks Yuri, Both fans ran for at least 2 hours before I noticed I had no heat. The unit has been sitting for 2 days in cool/cold temps outside, has been connected several times while I'm out there freezing. Still both fans come on every time, and I have no flame. By the way, my water heater is also natural gas and it works fine, and I paid my bill!!!

Dale
spearmad is offline   Reply With Quote
Old 12-04-2010, 06:27 AM   #13
Hvac Pro
 
Join Date: Nov 2008
Location: Winnipeg, Canada
Posts: 8,992
Default

Heil Gas Pack Burner Issue


Limit sits above the burners and probably looks like one of the round ones here
http://www.thefind.com/appliances/br...r-limit-switch
__________________
"Cut it twice and it is still too short".
yuri is offline   Reply With Quote
The Following User Says Thank You to yuri For This Useful Post:
spearmad (12-04-2010)
Old 12-04-2010, 06:28 AM   #14
Newbie
 
Join Date: Dec 2010
Posts: 5
Default

Heil Gas Pack Burner Issue


Thanks Beenthere, One month before then, I bought my house, and the filters looked new. I checked a month later, and replaced them.

Dale
spearmad is offline   Reply With Quote
Old 12-04-2010, 06:30 AM   #15
An old Tradesmen
 
Join Date: Oct 2008
Location: PA
Posts: 24,489
Default

Heil Gas Pack Burner Issue


I would suspect that the previous owners didn't change them on a regular basis. And new ones were put in to sell the house. Evap coil may also be dirty and causing your no heat.

Units needs a thorough check out.

beenthere is offline   Reply With Quote
The Following User Says Thank You to beenthere For This Useful Post:
spearmad (12-04-2010)
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Heil Furnace Burner Problem timothyr HVAC 79 02-12-2014 07:01 PM
Heil Gas pack: not all burners igniting cbaileyau HVAC 12 11-18-2010 05:56 AM
Bryant Gas pack Burner problem mswirtes HVAC 6 11-09-2010 11:25 AM
Goodman Furnace Burner issue hansim4 HVAC 5 10-08-2009 07:26 PM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.