DIY Chatroom Home Improvement Forum

DIY Chatroom Home Improvement Forum (http://www.diychatroom.com/)
-   HVAC (http://www.diychatroom.com/f17/)
-   -   heil furnace (http://www.diychatroom.com/f17/heil-furnace-6156/)

bbr67 01-27-2007 11:47 PM

heil furnace
 
I have a Heil SP80 furnace and at night or coldest period of day the furnace acts like it is going to come on then stops without firing. It repeats this cycle and at some point fires. I noticed it a couple years ago did think much of it. However this year it happens almost daily. If I increase the heat on the thermostat it fires right up and seems to function properly, Any ideas?? I did look to see if the flame sensor had build up but it does not.

#CARRIERMAN 01-28-2007 06:50 PM

Hi bbr67

It sounds like from your post you could have a pressure switch partially sticking. From the information you gave us I would say change out the pressure switch and you should have your problem fixed.

Good luck
Rusty

danwitte 02-01-2007 08:53 AM

Sp80
 
Quote:

Originally Posted by bbr67 (Post 31512)
I have a Heil SP80 furnace and at night or coldest period of day the furnace acts like it is going to come on then stops without firing. It repeats this cycle and at some point fires. I noticed it a couple years ago did think much of it. However this year it happens almost daily. If I increase the heat on the thermostat it fires right up and seems to function properly, Any ideas?? I did look to see if the flame sensor had build up but it does not.

I have exactly the same problem. Did you change out the pressure switch yet? Did that help? I've got 20 below coming in a couple days. It is always worse when it is cold.

Thanks,

Dan

PATMAN 02-02-2007 10:40 AM

I used to be a Heil dealer and ran into this problem once. It took me a lot of hours and calls to the manufacturer, but what we found was it had a bad molded plug, where the wires went through the furnace from the burner compartment to the blower compartment. You can try changing it yourself but it's a dealer item.

WATERMAN 02-23-2007 06:52 PM

Up until today, my Heil SP 80 would work for 1/2 day or so whenever I turned off the thermostat and then turned it back on at a high temp setting.

Now it will not fire up even if I take the proper steps to re-start the heater.

Any feedback? If it involves getting parts, what is my best resource for getting them.

Short on cash in Detroit.

rakes9720 02-24-2007 12:22 AM

Can you see what it does when you turn the thermostat up?
1. Inducer should run
2. Sometime later (less than 20 seconds), Igniter glows orange.
3. 17 seconds later gas valve clicks and burners light.
4. Blower fan turns on.

If you can tell where your furnace does not follow this, it will be helpful.


All times are GMT -5. The time now is 07:35 PM.


Copyright 2003-2014 Escalate Media LP. All Rights Reserved