DIY Chatroom Home Improvement Forum

DIY Chatroom Home Improvement Forum (http://www.diychatroom.com/)
-   HVAC (http://www.diychatroom.com/f17/)
-   -   Heil DC90, no heat (http://www.diychatroom.com/f17/heil-dc90-no-heat-120480/)

GoneFission 10-18-2011 11:15 AM

Heil DC90, no heat
 
I have a Heil DC90 in the attic of my garage, that is not working. The draft inducer fan comes one, the vacuum switches all trip, the HSI glows, but the main burner never comes on. The HSI just keeps glowing. Most times, I can see a small "pop" of a gas flame hear the pilot assembly, but it is impossible to view the pilot flame through the sight window.

I removed the pilot assembly, and carefully cleaned the flame rod with some scotchbrite, but I have not reinstalled the pilot assembly yet.

Just looking for some ideas on what to check next, if this doesn't work.

Is it OK to hook up the pilot assembly to the gas valve, outside of the burner box, to check the flame operation?

hvactech126 10-18-2011 05:56 PM

It is not ok to assemble the pilot outside of the burner box. You should remove the pilot orifice and clean it if at all possible. DO you have a honeywell SMARTVALVE gas valve? sounds like you do. try wiggling the wire to the valve. Those things are notorious for going bad.

GoneFission 10-18-2011 06:56 PM

Thanks! It is a Honeywell Smartvalve.

I put it back together, and turned it back on. it still goes to the same point, where the HSI never turns off, and the main gas valve doesn't open.

It looks like the pilot is getting a decent flame. I'm getting about a 70 millivolt signal back from the flame rod, wheneveer the pilot is on, so I think that my pilot and flame rod are working properly.

I'll try wiggling the wires, even though I've done about 20 "break and make" cycles with that connector already, while I was working on the pilot assembly.

Otherwise, would it be a bad Smartvalve? The furnace is about 14 years old

hvactech126 10-18-2011 09:23 PM

there is a high probability that the valve is bad. Flame signals are measured in micro amps DC not millivolts.

GoneFission 10-19-2011 07:29 AM

I'll see if my Fluke has a setting for DC micro amps.


All times are GMT -5. The time now is 12:02 PM.


Copyright 2003-2014 Escalate Media LP. All Rights Reserved