DIY Chatroom Home Improvement Forum

DIY Chatroom Home Improvement Forum (http://www.diychatroom.com/)
-   HVAC (http://www.diychatroom.com/f17/)
-   -   Heater Won't Heat (http://www.diychatroom.com/f17/heater-wont-heat-90252/)

Born2Ski 12-22-2010 01:11 PM

Heater Won't Heat
 
I have a Lennox Value Series Unit. I don't know the exact model #...if someone can tell me where to look for it, I can try to find it.

It worked perfectly fine for the AC this summer/fall, but when it came time to switch over to heat (gas), it wouldn't work.

When you turn on the thermostat, the unit turns on, the blower starts and then it makes a clicking noise as it tries to light. It will click, kick off, come back on, click again, kick off, etc. Everything (thermostat, blower, etc.) seems to work fine, except for lighting. The filters are new.

I haven't taken the front off of the unit because I don't want to end up causing a bigger problem. The only lights I can see are two green ones towards the top of the unit that blink.

Any advice would be appreciated!

Thanks!

Jackofall1 12-22-2010 02:23 PM

I would guess that the model number is on the inside of the upper panel.

Here is a link for a owners manual

http://www.cozyparts.com/lennox-part...p?TOPIC_ID=535

I believe there will be a legend to decipher the codes for the blinking LED's on the inside of the upper door.

hvaclover 12-22-2010 07:51 PM

From the way you describe it it sounds almost certainly to be the igniter.


All times are GMT -5. The time now is 09:50 PM.


Copyright 2003-2014 Escalate Media LP. All Rights Reserved