DIY Chatroom Home Improvement Forum

DIY Chatroom Home Improvement Forum (http://www.diychatroom.com/)
-   HVAC (http://www.diychatroom.com/f17/)
-   -   goodman pressure switch error 3 blinks (http://www.diychatroom.com/f17/goodman-pressure-switch-error-3-blinks-12608/)

mrbac 10-22-2007 06:51 PM

goodman pressure switch error 3 blinks
 
hello everyone. first post here.
i have two goodman furnaces. upstairs and downstairs. downstairs is giving out three blinks which indicates pressure switch. i have checked the vent and its clean. no condensation build up. i put a new hose on it just in case with no success. i swapped p-switch from upstairs unit and switch is good. the boards on these things i do see go bad but this one has had the board replaced about two years ago. the a/c still works and the board doesnt appear to have any burn outs.
what am i missing?
please help. wife and i and two of the four kids have health issues and we really cant afford to call a hvac guy out for something unless in dire need.
thanks
mrbac
ps the door switch is good as well.

HVACDave 10-22-2007 07:37 PM

Pressure switch eh, well you could have a couple of issues which could cause this code. as you have stated there could be a blockage in either the intake or the exhaust pipes. The easiest way to check for this is to undo the coupler on the intake pipe inside the furnace housing and let it draw in air from the furnace room for a couple of minutes and see if that is a fix. I have done the same with the exhaust, but only for a minute to check for a blockage(as you will create some CO while operating this way).
As you have also mentioned the drain issue sometimes causes problems. I have had to use a small piece of wire(like a coat hanger) and push through the fitting at the bottom fo the collector box before, where the hose ties onto the furnace burner box. If you have a build up of condensation in the secondary heat exchanger this can cause problems. The easiest fix for this is to ensure the furnace is sitting with a slight tilt to the front(like 1/8th inch back to front), so that the condensate runs to the collector box and out into the drain. You could also check to make sure that the ventor motor is getting up to speed(just in case a bearing is getting tight and slowing it down enough to not let enough flow through to trip the pressure switch.

Dave

mrbac 10-22-2007 07:47 PM

goodman
 
thanks Dave. I will check these other items for results in the morning as i have to go to my second job this evening. will let you know the results asap. thanks again for your fast reply Dave. it is much appreciated.

mrbac 10-22-2007 07:52 PM

goodman
 
Dave. YOU ROCK! i choose the easiest first since im trying to get to work. i used a brad nail and poked out the intake from the blower to the p-switch. viola! thanks Dave. if theres ever anything a computer tech/leather tooler can do for you let me know

zoeymithra 03-12-2013 12:43 AM

I also had this problem, and used the above advice to fix my furnace.
 
Here are the details. Goodman GMS80somethingsomething with 2 burners and the blower on the bottom. Furnace would start up, start the exhaust, light the burners, and as soon as the main blower would come on, shutdown and start over. :( After reading the post, and looking at a manual I found online for similar furnaces I checked the limit switches, and then I was able to ID the pressure switch for the exhaust vacuum pressure. It seems that it is a safety check system to make sure the exhaust is blowing/sucking enough. It was a circular plastic item a little bigger than a half dollar and about 1/2 an inch thick. It had a vacuum line going to it and two leads. I took the line off, and tested that it made clicking noises when I sucked on the line indicating that it was probably a working switch. Then I started the furnace while sucking on the line, and the furnace worked. This confirmed at the switch was working but not getting enough vacuum. I poked a long cotter pin into the hose barb on the exhaust housing and felt some kind of obstruction give way. After starting I put the lower panel back on, and started the furnace, the vacuum on the exhaust fan seemed to be a slightly louder whistle, and so I reattached the line, system is now functioning properly.

Thank you! :thumbsup:

-Zoey


All times are GMT -5. The time now is 01:19 PM.