DIY Chatroom Home Improvement Forum

DIY Chatroom Home Improvement Forum (http://www.diychatroom.com/)
-   HVAC (http://www.diychatroom.com/f17/)
-   -   Goodman Furnace wont stay running (http://www.diychatroom.com/f17/goodman-furnace-wont-stay-running-164850/)

handleonit 11-27-2012 07:54 AM

Goodman Furnace wont stay running
 
I have a goodman furnace, it wont stay running. I cleaned the flame sensor rod. it will run for a few minutes (about 5 or so) then shut off, blower motor seems to run fine, I dont know what else could be the problem, unit is approx 8-9 yrs old. Thanks for any advice, as my wife is about to throw a gasket, which will make this furnace problem see small in comparison...lol

jnc401 11-27-2012 08:19 AM

Sounds to me that you could possibly have one of three problems considering that you have alreaedy cleaned the flame sensor. The primary limit may be at fault considering that it is running long enough to get hot. Check your furnace diagram to see if you can pinpoint the placement of these limits (there are usually more than one). Secondly, there could possibly be something wrong with your thermostat or control board. Changing a thermostat is fairly easy but you may need to contact a professional to replace/test the control board. If you have more questions, we are a certified dealer of Goodman equipment and we can get any part that you might need. Visit us at www.homesplumbingsupply.com or call us at 812-882-1865

handleonit 11-27-2012 08:36 AM

Thanks, how else can I trouble shoot this problem

handleonit 11-27-2012 08:44 AM

Also when I turn the heat up, nothing seems to happen untill I turn system off then back on

handleonit 11-27-2012 09:11 AM

Checking the fault it says I have an open high limit switch?...how do I fix or clear it?

techpappy 11-27-2012 10:53 AM

the Hi Limit is a sensor that shuts down burners when heat exchanger gets too hot..this could be due to dirty filters or plugged AC Coil OR excessive dirt build up in circulating fan blades..OR all of the above.ensure all applicable items are clean...turning breaker off first of course..which will also reset control board to allow it to run again...if problem persists ..may be faulty sensor, electronics etc.


All times are GMT -5. The time now is 03:32 AM.