Furnace Problem - HVAC - DIY Chatroom Home Improvement Forum

Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC


Thread Tools Display Modes
Old 12-27-2008, 10:58 PM   #1
Join Date: Dec 2008
Posts: 1
Rewards Points: 10

Furnace Problem

So, im new here and im not sure if this goes into this section but... Today our furnace stopped working. Its an Amana Furnace im sure of the Make and model numbers. The LED indicator light blinked 4 Times which meant that the Roll out Switch was open. What Does this mean? Then a while later i checked the LED and it was 3 blinks which meant the Pressure Switch, even though we checked that already.

This happens when the Thermostat calls for heat.
1. I hear the fans and stuff
2. I look at the furnace and see the regular red glow
3. The furnace ignites and the flames are a regular blue color
4. about 20-30 seconds later it shuts off

We don't get any heat!
Please help


Juanacuna24 is offline   Reply With Quote
Old 12-28-2008, 10:13 PM   #2
30 year tech
hvac122's Avatar
Join Date: Dec 2007
Location: Lincoln, Nebraska
Posts: 427
Rewards Points: 250

Furnace Problem

Sounds like a dirty flame sensor. Clean it with scotchbrite and try it again.


hvac122 is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Heil Furnace Burner Problem timothyr HVAC 79 02-12-2014 08:01 PM
carrier furnace problem dqdave1 HVAC 14 02-06-2010 05:57 PM
Carrier Furnace Problem Boats1183 HVAC 1 11-11-2008 07:41 PM
another question for a miller furnace problem jb9270 HVAC 1 02-05-2007 03:04 PM
Furnace Blower Problem SGecko HVAC 2 09-27-2006 11:16 AM

Top of Page | View New Posts