Forums | Home Repair | Home Improvement | Painting | Interior Decorating | Remodeling | Landscaping


Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 01-22-2013, 11:07 AM   #1
Newbie
 
Join Date: Jan 2013
Posts: 6
Share |
Default

furnace problem


I havr a carrier model
58sx120-lg-1
When I turn the system on at the thermostat the power vent fan comes on but I never get any spark or pilot light.
I replaced the spark ignitor, but it seems as if it's not getting any power.
Any ideas on what I should check next would be greatly appreciated.

maple man is offline   Reply With Quote
Old 01-22-2013, 12:32 PM   #2
Member
 
Join Date: Sep 2011
Location: western Ny
Posts: 1,213
Default

furnace problem


It is posible that the pressure switch is not closing. A Volt meter can be used to see if it closing properly. Most likely cause is a clogged tube or a plugged exaust.

danpik is offline   Reply With Quote
Old 01-22-2013, 01:12 PM   #3
Newbie
 
Join Date: Jan 2013
Posts: 6
Default

furnace problem


I will have to check it out
maple man is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Heil Furnace Burner Problem timothyr HVAC 79 02-12-2014 07:01 PM
Gas Furnace Hiccups hugocraft HVAC 2 12-22-2012 06:50 AM
Quote for new furnace. Reasonable? dengle HVAC 16 03-04-2012 07:01 AM
Help with furnace blower problem Spydey HVAC 6 12-15-2010 08:18 PM
Old Silver-Line furnace problem avro1 HVAC 9 03-18-2010 12:01 AM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.