Furnace Not Working - HVAC - Page 2 - DIY Chatroom Home Improvement Forum


Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Display Modes
Old 04-21-2012, 06:57 PM   #16
Member
 
Join Date: Feb 2009
Location: St. Louis, MO
Posts: 93
Rewards Points: 75
Default

Furnace not working


House has central heat again. Bought a replacement control board. Naturally is showed up the day I was leaving for a week long trip. Got back yesterday, installed today.

I bought a used board from Amazon. Higher risk of a bad replacement but it was exactly the same model/part number. New replacement boards are now apparently a universal design with adapter wire bundle...a complication I chose to avoid. Plus they cost 3-4 times as much ($2-300 v $69).

The LED on the new board is on steady like the old board used to be. Apparently the rapid flashing LED on the old board was a pathetic cry for attention rather than any useable indication of onboard diagnostics.

Another adventure in home repair completed successfully. (fingers crossed)

Advertisement


Advertisement

mwpiper is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Carrier Furnace and Aprilaire not working meanj22 HVAC 3 01-03-2012 10:29 PM
Please help, furnace not working!!!!!! Sfeyelectric HVAC 7 03-31-2011 07:20 PM
Problems with new furnace..Overheating, having to reset. Furnace too big? Tommy2 HVAC 41 12-01-2008 02:55 PM
RUUD furnace not working blower runs ddeatrick99@hotmail.com HVAC 2 01-16-2008 10:55 PM
Furnace not working right TheBillman HVAC 2 11-20-2005 06:31 PM




Top of Page | View New Posts