DIY Chatroom Home Improvement Forum

DIY Chatroom Home Improvement Forum (http://www.diychatroom.com/)
-   HVAC (http://www.diychatroom.com/f17/)
-   -   furnace keeps igniting forever !! (http://www.diychatroom.com/f17/furnace-keeps-igniting-forever-38623/)

tommyle 02-18-2009 02:50 PM

furnace keeps igniting forever !!
 
1 Attachment(s)
Hi all,
My house is single dwelling , 2 stories. The upstair gas furnace is Bryant-day-and-night , model 394J . Some weeks ago , I noticed the clicking sound kept coming out from the furnace. Looking into the burner , I saw the pilot was on , but the ignitor kept arcing over and over. I reset the Tsat , then set the thermostat to overdrive mode , it appeared the furnace worked normally : ignitor on , next the pilot , then the burner flame up , and then blower on , but after about 30 seconds , the burner turned off , the blower stopped after that about 10 seconds , only pilot and ignitor stayed on forever. It also worked that way in other mode: hold , program...I already tried with new control board , new Tsat , to no hope. I turned off downstair furnace , guessing maybe not enough gas pressure for the upstair to run , but same thing happened. Please help . I include the furnace picture , if any more needed , please advise. Thanks for your time.

hvac122 02-18-2009 02:58 PM

I would guess a dirty pilot assembly. The pilot needs to prove itself on before main burners can come on.

tommyle 02-18-2009 03:55 PM

is pilot already there ?
 
Thanks. What i see is pilot is on after ignited , but main burner isn't on following , and why ignitor still working endlessly after pilot already on .Is that pilot already proved itself ?

hvac122 02-18-2009 04:09 PM

I would doubt it has proved itself. Just because its lit dosn't mean its proved. Try cleaning the pilot and orifice. Make sure there is a good strong pilot flame and that it is hitting the sensors. Also clean sensors with scotchguard.

HvacWiz 02-18-2009 09:20 PM

You will need to replace the 3 wire pilot assembly.

tommyle 02-19-2009 01:31 AM

thanks
 
I'll try the cleaning first before replacing the assembly. Hope the problem will be solved. Thanks

G71 02-19-2009 06:01 AM

Quote:

Originally Posted by HvacWiz (Post 232607)
You will need to replace the 3 wire pilot assembly.

I agree, just change it, you're prolonging the inevitable.

ajsellin2 10-19-2009 10:38 PM

This sounds very similar to a problem that I'm having with my 394G Bryant (Carrier) furnace.

Hoping that someone out there will be able to help me.

About eight months ago the igniter would spark continuously but would not light pilot and main furnace would not come on.

I had the pilot assembly LH680005 replace and it started working fine. Technition did note that after replacement, it took longer than it should for the pilot to to lite and main gas value to open thus starting the furnance.

I read some other threads that said it could be a control board or main value.

As this point, I'm going to replace the pilot assembly again and go from there.

Anyone have any additional suggestions?

Much appreciated !!:)


All times are GMT -5. The time now is 12:37 AM.


Copyright 2003-2014 Escalate Media LP. All Rights Reserved