Furnace Issues ...? - HVAC - DIY Chatroom Home Improvement Forum


Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Display Modes
Old 02-01-2013, 02:54 AM   #1
Newbie
 
Join Date: Feb 2013
Posts: 5
Rewards Points: 10
Default

Furnace Issues ...?


Hi...I came home from work and 15amp for the bedroom was tripped and the 60 AMP was tripped (and loose in the panel). I have an airtron furnace with a 30 AMP and 60 AMP breaker in the panel that both say "Furnace" on them. When I reset the breaker on the bedroom, everything was fine (for that circuit), but when I reset the 60 AMP breaker on the furnace, there was a light flicker and a wubba wubba sound, so I turned it back to off. Now, the furnace is still working while only using the 30 AMP breaker. Is this okay? Any ideas...?

House was a model built in 2006, furnace installed in 2006...
I bought the house in 2008

Advertisement

kieth5555 is offline   Reply With Quote
Old 02-01-2013, 03:48 AM   #2
Member
 
Join Date: Dec 2009
Posts: 637
Rewards Points: 500
Default

Furnace Issues ...?


Wubba wubba whuuuut? Is this an all electric furnace?

Advertisement

hvac benny is online now   Reply With Quote
Old 02-02-2013, 08:53 PM   #3
Member
 
Join Date: Aug 2012
Location: Canada ontario
Posts: 117
Rewards Points: 75
Default

Furnace Issues ...?


sounds like it may be a dead short if it is an electric furnace and a potenial fire hazzard and should be checked by a licenced tradesperson asap
hvac dude is offline   Reply With Quote
Old 02-04-2013, 12:27 AM   #4
Newbie
 
Join Date: Feb 2013
Posts: 5
Rewards Points: 10
Default

Furnace Issues ...?


to: hvac dude,

Thanks, I will!!
kieth5555 is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
carrier/payne furnace heat exchanger issues gomongo1 HVAC 9 11-29-2014 09:29 PM
Brand New Concord Furnace Doesn't Work In Cold Weather LeighC HVAC 21 01-07-2013 09:48 PM
Help Please... Furnace Issues timt09 General DIY Discussions 4 12-27-2009 12:46 AM
Luxaire Furnace Issues ElecEngineer262 HVAC 5 03-15-2009 12:02 PM
Problems with new furnace..Overheating, having to reset. Furnace too big? Tommy2 HVAC 41 12-01-2008 02:55 PM




Top of Page | View New Posts