DIY Chatroom Home Improvement Forum

DIY Chatroom Home Improvement Forum (http://www.diychatroom.com/)
-   HVAC (http://www.diychatroom.com/f17/)
-   -   Furnace hot serface ignighter prob (http://www.diychatroom.com/f17/furnace-hot-serface-ignighter-prob-172932/)

drisco 02-25-2013 10:09 AM

Furnace hot serface ignighter prob
 
Hi all I have a payne furnace mode 490aav036060 serial#0996a23659. When I turn on the furnace all sounds normal until the hot serface ignighter try's to light nothing happens besides smell of gas. I replaced the hot serface ignighter with no change.

jagans 02-25-2013 10:31 AM

1. Are you sure you got the right igniter?
2. Are all your condensate lines and trap clear?
3. Is your pressure switch closing?

Walk us through exactly what happens from call for heat by the T-Stat.

drisco 02-25-2013 11:13 AM

Yes I have the correct ignighter all lines are clear I will replace the pressure switch tomorrow and see if that fixes the problem

jagans 02-25-2013 12:38 PM

Sounds like you are going the same route as me igniter, pressure switch, then control board.

My problem was really the control board but it was damaged by leaking condensate, and the PS showed signs of getting wet too.

My fault for not cleaning trap and lines, Carriers fault for poorly designed secondary HE

yuri 02-25-2013 12:42 PM

I love the way people and some techs throw parts at the job until they hit it right. Wholesalers love that.:)

R U getting 120 volts to the igniter is the first place to start. You can carefully disconnect the molex plug at the igniter and check for voltage there up to the point where you smell gas going into the burners. If no voltage then the board is bad and at that age, 1996 unit, it more than likely is. Pressure switch is closed/proved/OK or the board would not turn on the gas to the burners.

drisco 02-26-2013 09:49 AM

I replaced the pressue switched no change hot surface ignighter not glowing but smell gas when after clicking noticed code 34

jagans 02-26-2013 10:01 AM

Yeah Yuri is probably correct. Bad Board. www.pexsupply.com

drisco 02-26-2013 02:01 PM

Ok thank u for help the volts coming out to hot serface ignighter is 2 when I start it and 12 after gas turns on if I hit top of circuit board it jumps up 120 200 for a second new circuit board time

yuri 02-26-2013 02:17 PM

There U go. :thumbsup: Try get an OEM Payne board as the generic aftermarket ones I don't like and the board is going to be a retofit now. Going to have a bunch of cables/harnesses and U need to be VERY careful how you plug this 16 pin flat connector onto the new board. Get it backwards and damage occurs. Usually if U look Very carefully at the board and the underside of that connector with a magifying glass there is a set of numbers 1-16 which need to line up and gives you the orientation. An OEM board in this case is better IMO. Carrier owns Payne so you may be able to get that board from a Carrier dealer. Try americanhvacparts.com but I don't know if they sell OEM parts, have to ask.

Good Luck

jagans 02-26-2013 06:08 PM

Yuri does it again! If you tap it and it works, it sounds like a bad connection, doesnt it Yuri?

Maybe that all importand ground screw is corroded? I would look at all solder joints with a Mag Glass and resolder any leads that look dull or like volcanoes.

drisco 02-26-2013 06:08 PM

I got icm282a fixed speed furnace control replacement module sould I keep this or take it back and get the factory oem I can't figure out the wiring on the discounted control module my fur part model number is hk42f20211 any help is most great full

yuri 02-26-2013 07:15 PM

Quote:

Originally Posted by jagans (Post 1125574)
Yuri does it again! If you tap it and it works, it sounds like a bad connection, doesnt it Yuri?

Maybe that all importand ground screw is corroded? I would look at all solder joints with a Mag Glass and resolder any leads that look dull or like volcanoes.


It is 17 yrs old and the igniter relay is shot and VERY soon the rest of it will B 2 so it really is time for a new one.

yuri 02-26-2013 07:17 PM

thats the problem with those dammnn discount non OEM parts. cables suckk and instructions are worse. get the OEM part as there are some specific features and timing etc that Payne had that Carrier didn't etc etc and I am sure the generics know nothing about.

drisco 02-26-2013 07:20 PM

90% of the furnace was rebuilt last year heat exchanger air pump blower motor but yes I agree it's in the plans for this summer

yuri 02-26-2013 07:25 PM

actually I meant the rest of the board is going to die/not feasible to repair but if you spent that much on repairs I would try make it last another 5 yrs. I looked at americanhvacparts.com site and it "looks" like they may have OEM boards but you should phone and make sure. the retrofit board/kit will have a different number but they can cross reference it if they don't have the original board (pretty sure they are gone).


All times are GMT -5. The time now is 12:15 AM.


Copyright 2003-2014 Escalate Media LP. All Rights Reserved