Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 01-16-2012, 03:15 PM   #1
Newbie
 
Join Date: Jan 2012
Posts: 4
Rewards Points: 10
Default

Furnace has burn smell and blower motor doesn't start


I have a Lennox 80UHG 3/4 - 100A-2

Problem: Thermostat calls for heat and the whole cycle starts up with the inducer runs, igniter lights up and flames burn for about a minute or so...usually the blower motor fires up and blows the heat thru the house, but the blower never comes on (I have had the blower motor tested and the capacitor too...both work and the fans spins freely with no issues) then shortly after it shuts off and give an error code LED1 (Slow Flash) LED2 (ON) and the description is Primary or Secondary Switch open. When the blower fan usually comes up I hear a click but nothing happens. The Metal plate that has the circut board mounted to it also has a separate bulky thing with several wires coming out that seems to hum pretty loud and I never remember hearing it before before and after the whole start up cycle...also once it shuts off the whole house smells like burnt wood...that seems to trickle out of the vents

Any Ideas?

marcusal6 is offline   Reply With Quote
Old 01-16-2012, 03:16 PM   #2
Member
 
Join Date: Feb 2007
Location: NW Ohio
Posts: 804
Rewards Points: 500
Default

Furnace has burn smell and blower motor doesn't start


Quote:
Originally Posted by marcusal6 View Post
I have a Lennox 80UHG 3/4 - 100A-2

Problem: Thermostat calls for heat and the whole cycle starts up with the inducer runs, igniter lights up and flames burn for about a minute or so...usually the blower motor fires up and blows the heat thru the house, but the blower never comes on (I have had the blower motor tested and the capacitor too...both work and the fans spins freely with no issues) then shortly after it shuts off and give an error code LED1 (Slow Flash) LED2 (ON) and the description is Primary or Secondary Switch open. When the blower fan usually comes up I hear a click but nothing happens. The Metal plate that has the circut board mounted to it also has a separate bulky thing with several wires coming out that seems to hum pretty loud and I never remember hearing it before before and after the whole start up cycle...also once it shuts off the whole house smells like burnt wood...that seems to trickle out of the vents

Any Ideas?
You have a bad HFR (heater fan relay) on the main board, you will need to have a qualified lennox tech out to replace the board.

harleyrider is offline   Reply With Quote
The Following User Says Thank You to harleyrider For This Useful Post:
marcusal6 (01-16-2012)
Old 01-16-2012, 03:22 PM   #3
I'm Your Huckleberry
 
Join Date: Mar 2011
Posts: 5,876
Rewards Points: 2,204
Default

Furnace has burn smell and blower motor doesn't start


What happens in cooling mode or fan on? It could be a bad relay or a bad fan motor/cap.
Doc Holliday is offline   Reply With Quote
Old 01-16-2012, 03:24 PM   #4
Member
 
Join Date: Feb 2007
Location: NW Ohio
Posts: 804
Rewards Points: 500
Default

Furnace has burn smell and blower motor doesn't start


Quote:
Originally Posted by Doc Holliday View Post
What happens in cooling mode or fan on? It could be a bad relay or a bad fan motor/cap.

quote taken from OP:

Quote:
(I have had the blower motor tested and the capacitor too...both work and the fans spins freely with no issues)
harleyrider is offline   Reply With Quote
Old 01-16-2012, 03:27 PM   #5
I'm Your Huckleberry
 
Join Date: Mar 2011
Posts: 5,876
Rewards Points: 2,204
Default

Furnace has burn smell and blower motor doesn't start


hAiR today, bAld tomorrow.
Doc Holliday is offline   Reply With Quote
Old 01-16-2012, 03:31 PM   #6
I'm Your Huckleberry
 
Join Date: Mar 2011
Posts: 5,876
Rewards Points: 2,204
Default

Furnace has burn smell and blower motor doesn't start


A burn smell is usually the motor. Good luck.
Doc Holliday is offline   Reply With Quote
Old 01-16-2012, 03:39 PM   #7
Member
 
Join Date: Feb 2007
Location: NW Ohio
Posts: 804
Rewards Points: 500
Default

Furnace has burn smell and blower motor doesn't start


Quote:
Originally Posted by Doc Holliday View Post
A burn smell is usually the motor. Good luck.
I guess you have never seen a circut board that blew a relay off of it? i have seen it a thousand times, can smell it when i pull in the driveway............yeah, im that good
harleyrider is offline   Reply With Quote
Old 01-16-2012, 03:52 PM   #8
Newbie
 
Join Date: Jan 2012
Posts: 4
Rewards Points: 10
Default

Furnace has burn smell and blower motor doesn't start


[QUOTE=Doc Holliday;824674]What happens in cooling mode or fan on? It could be a bad relay or a bad fan motor/cap.[/QUOTE

the blower motor doesn't run in cool or fan mode...so nothing happens
marcusal6 is offline   Reply With Quote
Old 01-16-2012, 03:57 PM   #9
Member
 
Join Date: Feb 2007
Location: NW Ohio
Posts: 804
Rewards Points: 500
Default

Furnace has burn smell and blower motor doesn't start


post a picture of your circuit board..........it will show a fried relay, you will see black soot and smell the cooked relay. we can have 20 or 30 more post about what could be wrong in 50 different pretend scenario's if you would like.........
harleyrider is offline   Reply With Quote
Old 01-16-2012, 05:00 PM   #10
Newbie
 
Join Date: Jan 2012
Posts: 4
Rewards Points: 10
Default

Furnace has burn smell and blower motor doesn't start


Quote:
Originally Posted by harleyrider View Post
post a picture of your circuit board..........it will show a fried relay, you will see black soot and smell the cooked relay. we can have 20 or 30 more post about what could be wrong in 50 different pretend scenario's if you would like.........
Thanks Harley Rider!!!...I took the board off and you are exactly right...black spot on the back of the board...getting costs for a new one...so far $223 is the only cost I got...the rest of the shops are closed around here...does $223 seem like a fair price?

the board had a label on it for part info...
9840
50A65-120
Lennox
12L6901
marcusal6 is offline   Reply With Quote
Old 01-16-2012, 05:01 PM   #11
Member
 
Join Date: Feb 2007
Location: NW Ohio
Posts: 804
Rewards Points: 500
Default

Furnace has burn smell and blower motor doesn't start


yes......thats a good price !
harleyrider is offline   Reply With Quote
Old 01-17-2012, 02:47 PM   #12
Newbie
 
Join Date: Jan 2012
Posts: 4
Rewards Points: 10
Default

Furnace has burn smell and blower motor doesn't start


Quote:
Originally Posted by harleyrider View Post
yes......thats a good price !
New board dropped in and heat is up and running. There is still a slight burning smell coming from the heater at startup...maybe it's just some felt over smell???...not as strong as before. Could there have been another problem in the furnace to cause the short in the relay...I just don't want to burn out the new board... do you have any idea what causes the blown relay? I just want to avoid this if at all possible.

you gave great advice and knew exactly what was wrong

Thanks Again!
marcusal6 is offline   Reply With Quote
Old 01-17-2012, 02:54 PM   #13
HVAC Tech/ Browns Fan
 
Join Date: Dec 2009
Location: Dayton, ohio
Posts: 541
Rewards Points: 500
Default

Furnace has burn smell and blower motor doesn't start


Quote:
Originally Posted by harleyrider View Post
I guess you have never seen a circut board that blew a relay off of it? i have seen it a thousand times, can smell it when i pull in the driveway............yeah, im that good
Heck I'm better. I can smell it over the phone when I'm talking to the customer.
Tator1076 is offline   Reply With Quote
Old 01-17-2012, 03:09 PM   #14
how
Member
 
Join Date: Feb 2011
Location: Vancouver BC
Posts: 1,498
Rewards Points: 512
Default

Furnace has burn smell and blower motor doesn't start


That smell should be a 1/8 th of what it was but it will hang around for a few more days.

how is online now   Reply With Quote
The Following User Says Thank You to how For This Useful Post:
harleyrider (01-17-2012)
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bad smell in crawl space. John_W General DIY Discussions 34 06-03-2014 12:57 PM
Blower on Furnace Keeps Going Out gatesj1221 HVAC 6 02-09-2011 02:35 PM
Smell coming from all floor registers. John_W HVAC 9 06-27-2010 09:57 AM
Ruud Furnace blower /igniter jammerdc79 HVAC 1 11-17-2009 06:13 PM
Gas Furnace - Burning smell at return blakemcginnis HVAC 4 01-26-2008 08:29 AM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.