Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 05-15-2012, 10:03 PM   #1
Member
 
Join Date: May 2012
Posts: 85
Rewards Points: 75
Default

Frost on accumulator line a/c not DIY but questions for tech when he comes


Recently went thru an a/c checkup and replacement of the condenser fan motor and cap with help on this site.

Tech did a checkup and hooked up his gauges, said everything looked good.

Today when I watched the a/c come on, I see frost forming on what I believe is the accumulator (see pic). It goes after after a few minutes.

I'm going to have another company come out. What questions should I ask? What should I tell them to help diagnose? Any possible guesses as to what the issue is?
Attached Thumbnails
Frost on accumulator line a/c not DIY but questions for tech when he comes-frost.jpg  


Last edited by wheelsup; 05-15-2012 at 11:29 PM.
wheelsup is offline   Reply With Quote
Old 05-16-2012, 08:02 PM   #2
Supplier
 
Join Date: Sep 2008
Location: CA
Posts: 24
Rewards Points: 10
Default

Frost on accumulator line a/c not DIY but questions for tech when he comes


Yes that is the suction accumulator. It is no big deal if there is a little frost on it or the tubing as long as you don't have a lot on them or/and on the compressor which indicates a liquid flood back.

gsistore is offline   Reply With Quote
The Following User Says Thank You to gsistore For This Useful Post:
wheelsup (05-17-2012)
Old 05-17-2012, 01:42 AM   #3
Member
 
Join Date: May 2012
Posts: 85
Rewards Points: 75
Default

Frost on accumulator line a/c not DIY but questions for tech when he comes


Quote:
Originally Posted by gsistore View Post
Yes that is the suction accumulator. It is no big deal if there is a little frost on it or the tubing as long as you don't have a lot on them or/and on the compressor which indicates a liquid flood back.
Thanks gsi

I was able to call the company who came out 1-2 weeks ago and the dispatcher contacted the tech. He called Carrier tech support who told him it's fine just like you said. Perfectly normal. So I'm happy!

No frost anywhere but on that line and only on start.
wheelsup is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mobile Home Carpentry questions immeraufdemhund Carpentry 3 11-19-2010 07:52 AM
Newbie with questions about a 4 ton rheem nissan4x4 HVAC 4 05-25-2010 12:53 AM
A few roof questions before I begin... chrisexv6 Roofing/Siding 6 05-02-2010 07:16 AM
Aluminum-wired house, questions LMH Electrical 2 05-24-2009 04:06 AM
tiling questions - in middle of install mwill Flooring 8 12-11-2007 06:06 PM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.