DIY Chatroom Home Improvement Forum

DIY Chatroom Home Improvement Forum (http://www.diychatroom.com/)
-   HVAC (http://www.diychatroom.com/f17/)
-   -   Force air gas furnace HELP!!!! (http://www.diychatroom.com/f17/force-air-gas-furnace-help-161598/)

Hawkeye40 10-30-2012 08:17 AM

Force air gas furnace HELP!!!!
 
I posted once before and I was really lacking any real detail, so this time I have more information. This morning I tried again and this is what I got. I checked my pressure switch and lines all were good. I turned it on and it went through its cycle. The igniter burned like a deep orange then to blue then the blower kicked on. It ran for a few minutes and it turned off with the warning light that says "Gas Valve Relay Short or False Flame." I'm not all that sure what that means. I turned it off and then back on it ran longer about 2 cycles then it clicked off warning light reading this time "Limit Circuit open or External Lead Stuck on "W". I for one am confused by all this any help would be great.

So its been about maybe a half hour if that. It still runs I hear the gas igniting and the force air is still pumping out hot air through the house. I'm not sure if thats normal or if the problem sorted itself out. We just had the hurricane pass through here so I'm not all that sure if it was from that I did have to change out the motor for the force air and I hooked everything back up correctly. Thinking I should go through and re-tighten the ground leads that I had to unhook.

beenthere 10-30-2012 03:34 PM

Bad grounds can cause all sorts of error codes.

Hawkeye40 10-31-2012 02:19 AM

That's what I figured. The one ground bolt was corroded so it took a bit. I'll have to go through my coffee cans of bolts see if that is it. Thanks


All times are GMT -5. The time now is 08:08 AM.


Copyright 2003-2014 Escalate Media LP. All Rights Reserved