Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 09-20-2011, 09:22 AM   #1
Newbie
 
Join Date: Sep 2011
Posts: 4
Rewards Points: 10
Question

Concord 90 + high efficiency gas furnace


I am hoping someone can help me . When I turned my furnace on , all its doing is blowing cold air . I can hear water running threw but my pilot light won't light . I can't afford an repairman . Any suggestions. Thankyou

ahamerik is offline   Reply With Quote
Old 09-20-2011, 09:45 AM   #2
fabrk8r
 
fabrk8r's Avatar
 
Join Date: Feb 2010
Location: Iowa
Posts: 849
Rewards Points: 500
Default

Concord 90 + high efficiency gas furnace


If you are hearing water you may have a plugged condensate and the water is sloshing around in the draft inducer fan housing. If this is the case some water may have gotten into the draft inducer air switch (vacuum diaphragm switch).

__________________
"The physician can bury his mistakes, but the architect can only advise his clients to plant vines." -- Frank Lloyd Wright
fabrk8r is offline   Reply With Quote
Old 09-20-2011, 09:49 AM   #3
Newbie
 
Join Date: Sep 2011
Posts: 4
Rewards Points: 10
Default

Concord 90 + high efficiency gas furnace


Thankyou , but how do I fix this
ahamerik is offline   Reply With Quote
Old 09-20-2011, 10:23 AM   #4
fabrk8r
 
fabrk8r's Avatar
 
Join Date: Feb 2010
Location: Iowa
Posts: 849
Rewards Points: 500
Default

Concord 90 + high efficiency gas furnace


Open the access cover and check to see if the drain hose from the inducer fan is plugged.

You may need a pair of pliers to remove the hose clamp. Have a towel ready because if it's plugged there will be a lot of cruddy water that will drain out.
__________________
"The physician can bury his mistakes, but the architect can only advise his clients to plant vines." -- Frank Lloyd Wright
fabrk8r is offline   Reply With Quote
Old 09-20-2011, 11:35 AM   #5
Newbie
 
Join Date: Sep 2011
Posts: 4
Rewards Points: 10
Default

Concord 90 + high efficiency gas furnace


Quote:
Originally Posted by fabrk8r View Post
Open the access cover and check to see if the drain hose from the inducer fan is plugged.

You may need a pair of pliers to remove the hose clamp. Have a towel ready because if it's plugged there will be a lot of cruddy water that will drain out.
I will try this after work. Thankyou
ahamerik is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gas Furnace Won't Stay Running / Thermostat Set High To Start _scott HVAC 6 03-23-2011 08:27 PM
high efficiency furnace exhaust pointing upward? flyorange HVAC 10 01-07-2011 11:18 PM
High Efficiency furnace water leak drtbk4ever HVAC 10 03-21-2009 12:17 AM
New Cased Coil - Install to Furnace - PICTURES!! hartkem HVAC 39 11-18-2008 02:45 AM
High Efficiency furnaces? jetchaser HVAC 3 06-19-2008 08:33 AM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.