Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 05-25-2010, 06:47 PM   #1
Newbie
 
Join Date: May 2010
Posts: 1
Share |
Default

compressor works no fan


My 2 ton packaged unit gas/ac unit has a working ac compressor but air is not circulating and blowing into the house and returning back to unit.

I put a new capacitor on recirculating blower motor 4 days back when i first noticed this..
Outside coil cooling fan/motor runs fine.
Recirculating fan motor is OK according to folks at electric motor repair place.
After installing new capacitor,(which may not have even been bad) AND letting the ice melt off the coils which was blocking air flow unit worked fine.(4 days back)
now after 4 days i've checked and compressor and cooling coil is iced up and no air is circulating.

Could something be causing the coils to ice up, thus blocking air flow, or is this a symptom of the fan not working?


Last edited by Elias2; 05-25-2010 at 06:58 PM.
Elias2 is offline   Reply With Quote
Old 05-25-2010, 07:30 PM   #2
Hvac Pro
 
Join Date: Nov 2008
Location: Winnipeg, Canada
Posts: 9,410
Default

compressor works no fan


See if the fan is trying to run when the coil is iced up. The relay on the circuit board that turns the fan on may be sticking off and causing the same problem. If the coil is dirty and the unit low on freon it can ice up and should be checked by a Pro.

__________________
"Cut it twice and it is still too short".
yuri is online now   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off





Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.