DIY Chatroom Home Improvement Forum

DIY Chatroom Home Improvement Forum (http://www.diychatroom.com/)
-   HVAC (http://www.diychatroom.com/f17/)
-   -   Comfortmaker Furnace GUH Series Issue (http://www.diychatroom.com/f17/comfortmaker-furnace-guh-series-issue-6264/)

Ghengis Jon 02-02-2007 09:24 AM

Comfortmaker Furnace GUH Series Issue
 
I've got a mid '90s CM furnace. There's a little run-on of the fan once the heat kicks off, I believe this to be normal operation. (The heat and fan kick on as usual, temperature reaches desired level, heat kicks off, then the fan kicks off a minute later.) Now, about once a week, the fan won't turn off. The heat and fan come on, temperature is reached, the heat turns off, but the fan continues to run. The temp drops past the level where the heat should come on again, but it doesn't. The result is the fan continues to run without shutting off. Turning the power switch off and then back on returns the unit back to normal operation for another week. The diagnostic LED either shows steady on (internal board failure) or constant blinking (external failure) with no consistancy for the error code displayed. I've already replaced the pressure switch with no effect. What do you experts suspect is the issue? Should I buy a replacement control module? Thx - Jon

#CARRIERMAN 02-02-2007 04:21 PM

Hi Ghengis Jon

Check your furnace filter, it sounds like you are having a limit trip problem for the blower and inducer to be running at the same time with no heat. Or you could be having an ingition failure caused by a dirty flame sensor. Shut the power off to the furnace. Locate and pull the stainless steel rod. Use steel wool or a wire brush and clean rod. Reinstall the rod, power the furnace back up and see if that fixes the problem. If not let me know and we will go a step further.

Good luck
Rusty

Ghengis Jon 02-05-2007 08:38 AM

Thanks! I did remove and clean the flame sensor. (The furnace filter was replaced with new 2 months ago.) Should I need to replace the flame sensor, I have a question concerning its construction. I see flame sensors are offered both with and without the cable. The one in my furnace does not seem to have a detachable lead - the lead runs through a wire bundle up to a molded connector. If replacement is required, can I cut the wire and splice in the new sensor? Or is this a multi wire lead (like a coaxial cable) that would rule out splicing? The molded connector seems to be designed NOT to have leads removed and replaced....

Ghengis Jon 02-05-2007 06:49 PM

Flame Sensor?
 
Well, cleaning the sensor did ot resolve the issue stated in my first post. Same thing happened but the blinkcode now tells me "Flame sensed with no call for flame". There is no flame going at this time. I'm thinking the cheapest (and hopefully easiest) route is to replace the sensor. But I wonder if I shouldn't spring for the control module too, if nothing else to have on the shelf for future needs.

Further thoughts? Am I going down the right road?

angel 02-28-2007 04:42 PM

I am having problems with my Comfortmaker. There is a round plastic part that is broken and i have ordered the part from Sears and received the wrong part twice. I have called several places and either they don't sell comfortmaker parts or they sell an entire assembly with that part included for $384. I've went to the comfortmaker website and of course they only show new furnaces. Does anyone know of anyone or anyplace that sells parts from used furnaces. I feel that this is the only way i can buy a part that is usually not sold on it's own. I have several names of the part that i am trying to find. I have been told that it is a draft inducer, a venter motor, a combustion blower, and a blower wheel. I believe the blower wheel is definitely not correct. The part is two circular clear plastic pieces with a diameter of about 10 inches glued together with a 1 inch space in between the pieces with chambers inside the one inch space. It spins around with a plastic piece that sticks out from the middle that keeps it from rubbing onto another separate piece. I have someone who can replace the part if we can just get our hands on one. I live in Illinois and have been freezing my butt off for the last 8 days. Please help.

harleyrider 02-28-2007 09:16 PM

Quote:

Originally Posted by Ghengis Jon (Post 32136)
I've got a mid '90s CM furnace. There's a little run-on of the fan once the heat kicks off, I believe this to be normal operation. (The heat and fan kick on as usual, temperature reaches desired level, heat kicks off, then the fan kicks off a minute later.) Now, about once a week, the fan won't turn off. The heat and fan come on, temperature is reached, the heat turns off, but the fan continues to run. The temp drops past the level where the heat should come on again, but it doesn't. The result is the fan continues to run without shutting off. Turning the power switch off and then back on returns the unit back to normal operation for another week. The diagnostic LED either shows steady on (internal board failure) or constant blinking (external failure) with no consistancy for the error code displayed. I've already replaced the pressure switch with no effect. What do you experts suspect is the issue? Should I buy a replacement control module? Thx - Jon


It doesent take rocket sience to figure this one out..........the board controls the blower and it is soley responesable for the intermitant problems that you are experenceing. Change the board and get on with life. Have a nice day!

harleyrider 02-28-2007 09:18 PM

Quote:

Originally Posted by angel (Post 35095)
I am having problems with my Comfortmaker. There is a round plastic part that is broken and i have ordered the part from Sears and received the wrong part twice. I have called several places and either they don't sell comfortmaker parts or they sell an entire assembly with that part included for $384. I've went to the comfortmaker website and of course they only show new furnaces. Does anyone know of anyone or anyplace that sells parts from used furnaces. I feel that this is the only way i can buy a part that is usually not sold on it's own. I have several names of the part that i am trying to find. I have been told that it is a draft inducer, a venter motor, a combustion blower, and a blower wheel. I believe the blower wheel is definitely not correct. The part is two circular clear plastic pieces with a diameter of about 10 inches glued together with a 1 inch space in between the pieces with chambers inside the one inch space. It spins around with a plastic piece that sticks out from the middle that keeps it from rubbing onto another separate piece. I have someone who can replace the part if we can just get our hands on one. I live in Illinois and have been freezing my butt off for the last 8 days. Please help.


Post a picture...then I will give you a definate answer.

harleyrider 02-28-2007 09:20 PM

Quote:

Originally Posted by #CARRIERMAN (Post 32201)
Hi Ghengis Jon

Check your furnace filter, it sounds like you are having a limit trip problem for the blower and inducer to be running at the same time with no heat. Or you could be having an ingition failure caused by a dirty flame sensor. Shut the power off to the furnace. Locate and pull the stainless steel rod. Use steel wool or a wire brush and clean rod. Reinstall the rod, power the furnace back up and see if that fixes the problem. If not let me know and we will go a step further.

Good luck
Rusty


With all due respect.............did you read his post before you replyed?

angel 03-01-2007 03:02 PM

Harleyrider:
I don't have a picture but will definitely post one if the parts store in my town doesn't have this part. After calling around all day yesterday a parts dealer was located who claims he knows the part we need and has one. so we're taking the part in today to see if it's the right one. If not, I will post a picture of it so someone can please tell me the name of the part and if it can be purchased separately. thanks for replying.


All times are GMT -5. The time now is 05:13 PM.