Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 01-18-2009, 12:09 PM   #1
Newbie
 
Join Date: Jan 2009
Posts: 1
Share |
Default

central heating


We have a Coleman Evcon electric heating system. All of a suddenit is not sending out any heat. We can turn the fan on,it works, but no heat. Any ideas? Thanks.


Last edited by cyndy; 01-18-2009 at 12:18 PM. Reason: proper system info
cyndy is offline   Reply With Quote
Old 01-18-2009, 02:55 PM   #2
Member
 
JohnH1's Avatar
 
Join Date: Jan 2009
Location: Chicago, IL.
Posts: 428
Default

central heating


If the fan turns on with a call for heat you probly have bad elements. If you are turning the fan on manually it is probly a bad sequencer. Eather require a pro to work on these both involve high voltage and can be very dangerious.

JohnH1 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Central heating help please!!! arif101 HVAC 3 10-19-2008 07:05 PM
hot water and central heating wont work independently khanay Plumbing 2 07-12-2008 03:14 PM
Central Heating Frustration SassySue General DIY Discussions 4 11-29-2007 06:46 AM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.