Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 01-13-2013, 07:04 PM   #1
Newbie
 
Join Date: Jan 2013
Posts: 1
Rewards Points: 10
Default

Carrier Weathermaker 58sx with HH84AA021


I have a Carrier Weathermaker 58SX with an HH84AA021 control board. The sequence of operation seems to works fine through when the burner ignite. The burner runs for about 3 minutes turn off and the fan comes on. It started doing this when I replace the original board with the new one.

This cannot be the way this is suposed to run is it? Where should I look for the problem.

arnett1227 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Carrier 58SX drain Problem rundquist HVAC 4 11-15-2011 12:11 PM
Carrier Weathermaker 9200 klrz28 HVAC 24 04-23-2011 07:37 PM
Carrier 9200 Weathermaker Won't Start tcrescenzo HVAC 12 02-22-2011 03:44 PM
Carrier Weathermaker SX mikeschu HVAC 1 11-01-2010 04:13 AM
Carrier Weathermaker 58SX Gas Tech HVAC 4 05-06-2009 08:04 PM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.