Forums | Home Repair | Home Improvement | Painting | Interior Decorating | Remodeling | Landscaping


Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 04-02-2013, 08:59 PM   #1
Newbie
 
Join Date: Apr 2013
Posts: 3
Share |
Default

Carrier ICM271C control board fails after 1 season


I have a Carrier model 58DR075 furnace and every year I have to replace the fan control board. When I install a new one it works fine but eventually it gets to the point where when the fan comes on the flame goes out. The unit will try to restart but as long as the blower is running the flame will not stay lit. Once I replace the blower control the unit is fine for about 1 year then the same failure happens again. This has been going on for 7 years now. Any ideas as to why this is happening and how it can be resolved? Thanks from a newb!

Britcarfxr is offline   Reply With Quote
Old 04-02-2013, 09:03 PM   #2
Member
 
Join Date: Oct 2011
Location: pa
Posts: 4,019
Default

Carrier ICM271C control board fails after 1 season


are there any error codes on control board pointing to some direction to go and picture of furnace with doors off will help along with close up of control board..ben sr

ben's plumbing is offline   Reply With Quote
Old 04-03-2013, 07:59 PM   #3
Newbie
 
Join Date: Apr 2013
Posts: 3
Default

Carrier ICM271C control board fails after 1 season


I don't see a way to get error codes from this board. There is not LED or test port on it. Even with a new control board there seems to be an issue getting the flame to stay lit. Once the thermo calls for heat the igniter will strike for quite awhile before the pilot lights then the gas valve will open and the flame lights only to go out in a few seconds. Then the same process starts all over again. Then finally it will stay lit and the furnace works normally. I am using an ICM271C control board btw. Here are the pictures. Thanks!
Attached Thumbnails
Carrier ICM271C control board fails after 1 season-img_20130403_193925.jpg   Carrier ICM271C control board fails after 1 season-img_20130403_193812.jpg  
Britcarfxr is offline   Reply With Quote
Old 04-03-2013, 09:26 PM   #4
Member
 
Join Date: Oct 2012
Posts: 263
Default

Carrier ICM271C control board fails after 1 season


Quote:
Originally Posted by Britcarfxr View Post
I don't see a way to get error codes from this board. There is not LED or test port on it. Even with a new control board there seems to be an issue getting the flame to stay lit. Once the thermo calls for heat the igniter will strike for quite awhile before the pilot lights then the gas valve will open and the flame lights only to go out in a few seconds. Then the same process starts all over again. Then finally it will stay lit and the furnace works normally. I am using an ICM271C control board btw. Here are the pictures. Thanks!
I don't know why, but the function of changing the fan control board is somehow making the pilot assembly work right for awhile. The control board has nothing to do with pilot other than supplying low voltage power to the components that light the pilot. The pilot assembly itself is what proves the pilot being lit and allowing the furnace to transition to main burner.

First of all the pilot should light within the first few sparks. Once lit is should be a nice blue well defined flame. I suspect the real problem is with the pilot assembly. The other thing you mentioned is that as soon as the blower comes on the pilot/flame goes out. This is NOT a good indicator. It can indicate a failed heat exchanger.

I suggest you have a qualified Carrier service tech take a look at the furnace.
old_squid is offline   Reply With Quote
The Following User Says Thank You to old_squid For This Useful Post:
ben's plumbing (04-04-2013)
Old 04-03-2013, 10:28 PM   #5
Newbie
 
Join Date: Apr 2013
Posts: 3
Default

Carrier ICM271C control board fails after 1 season


I did have a qualified Carrier tech check it out. He is the one who first changed the control board. I forgot to mention that over the years we have lived here I have replaced the pilot (which does have a nice blue flame) and the pilot controller. Both of those items failed at different times but nothing has resolved the problem completely.
Britcarfxr is offline   Reply With Quote
Old 04-04-2013, 12:21 AM   #6
how
Member
 
Join Date: Feb 2011
Location: Vancouver BC
Posts: 1,473
Default

Carrier ICM271C control board fails after 1 season


The major excuse most board manufactures claim for repeated failures is poor grounds. I've certainly sorted out instals with repeated board failures by fixing poor grounds anywhere between the board, all the way back to the main house ground.

how is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kenmore Eleite Dishwasher - no leds on control board inmars Appliances 0 11-03-2012 07:57 AM
new furnace control board same problems? jeremptucker HVAC 4 10-20-2012 01:11 AM
Test control board/ hot wire blower motor mcompton1973 HVAC 8 10-07-2012 11:50 PM
New control board or fix it? Bobeht HVAC 26 01-18-2012 03:03 PM
Ruud a/c control board replacement ? kourso HVAC 1 07-20-2006 09:33 PM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.