DIY Chatroom Home Improvement Forum

DIY Chatroom Home Improvement Forum (http://www.diychatroom.com/)
-   HVAC (http://www.diychatroom.com/f17/)
-   -   Carrier gas pack won't ignite, pressure switch doesn't close (http://www.diychatroom.com/f17/carrier-gas-pack-wont-ignite-pressure-switch-doesnt-close-88332/)

TNFrank 12-01-2010 06:17 PM

Carrier gas pack won't ignite, pressure switch doesn't close
 
Don't know the model number but its an 18 year old, 3 ton package system that I'm going to replace soon. System was working fine, then yesterday found fan running but no heat. Found fan wheel had rusted and broken off of the inducer motor, replaced fan wheel but still won't ignite because pressure switch isn't closing. If I jump pressure switch, burner will ignite but soon shuts down because roll out switch opens (didn't start without access panel in place). Seems to be air flow problem but can't find anything clogged, cracked, broken or otherwise degraded and it was working fine a couple of days ago. The new fan wheel is correctly installed and the inducer motor seems to be working fine. Any thoughts? Thanks!

kenmac 12-01-2010 07:46 PM

Quote:

Originally Posted by TNFrank (Post 543814)
Don't know the model number but its an 18 year old, 3 ton package system that I'm going to replace soon. System was working fine, then yesterday found fan running but no heat. Found fan wheel had rusted and broken off of the inducer motor, replaced fan wheel but still won't ignite because pressure switch isn't closing. If I jump pressure switch, burner will ignite but soon shuts down because roll out switch opens (didn't start without access panel in place). Seems to be air flow problem but can't find anything clogged, cracked, broken or otherwise degraded and it was working fine a couple of days ago. The new fan wheel is correctly installed and the inducer motor seems to be working fine. Any thoughts? Thanks!



18 yr old carrier :( probably cracked or hole rusted through somewhere

hvactech126 12-01-2010 09:39 PM

big chance the heat exchanger has a hole in it. or something is blocking the vent. there is a reason why the p/s is not closing

TNFrank 12-02-2010 05:42 PM

Thanks guys, its clearly time for a new one!


All times are GMT -5. The time now is 04:17 PM.