Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 11-11-2008, 06:01 PM   #1
Newbie
 
Join Date: Nov 2008
Location: Ohio
Posts: 1
Rewards Points: 10
Default

Carrier Furnace Problem


I have a carrier furnace model 58SX-060-GG-1 series 190.
My problem began when condensation shorted out the circuit board and the draft inducer motor. I replaced the circuit board and motor but during startup the pilot would light and when the furnace would go to start the blower motor it would blow the ATO 3 fuse. I called a technician and he stated that it may be the wiring harness because it had a bad fitting. I replaced the harness but am having the same problem.
Can anyone help!

Boats1183 is offline   Reply With Quote
Old 11-11-2008, 06:41 PM   #2
Member
 
Join Date: Nov 2008
Location: palm coast fl
Posts: 588
Rewards Points: 500
Default

Carrier Furnace Problem


are u sure its completely dry on the circuit board? if yes the low voltage side of the fan control on the board is most likely bad which means youll need to rpl the board also

kennzz05 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Carrier furnace problem? 4merfigur8er HVAC 15 11-08-2011 10:06 AM
carrier furnace problem dqdave1 HVAC 14 02-06-2010 04:57 PM
Carrier furnace problem 4merfigur8er HVAC 1 01-19-2008 04:47 PM
another Carrier furnace problem jhrodd HVAC 5 02-18-2007 12:09 AM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.