Carrier Furnace Keeps Running - HVAC - DIY Chatroom Home Improvement Forum


Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Display Modes
Old 02-03-2008, 04:18 PM   #1
Newbie
 
Join Date: Feb 2008
Posts: 4
Rewards Points: 10
Default

Carrier furnace keeps running


My Carrier gas furnace (Model 58SE 125, Series No.404) keeps running and never shuts off. Thermostat seems to be working fine, but cold air keeps on coming. Is this caused by "Fusible Element" ?
Any advise for this novice DIY-er would be appreciated.

Advertisement

tnakano is offline   Reply With Quote
Old 02-03-2008, 05:14 PM   #2
Member
 
biggles's Avatar
 
Join Date: Jan 2008
Location: Long Island
Posts: 3,630
Rewards Points: 2,000
Default

Carrier furnace keeps running


make sure the stat is set for heat and.set to 75F(FOR TESTING)....fan is in the auto position.check your filter clean..can you see light when you hold it up to the light...its good if you can.shut the switch on the side of the furnace off count to 10 then put it back on,,,get back here and note what you hear clicks,fan burner flue gets warm????

Advertisement

biggles is offline   Reply With Quote
Old 02-03-2008, 07:35 PM   #3
Newbie
 
Join Date: Feb 2008
Posts: 4
Rewards Points: 10
Default

Carrier furnace keeps running


Thank you very much for a quick reply.

The following functions work properly.
(1) Pilot on-off
(2) Burner on-off according to temperature setting
(3) Filter is fresh and clean

The only problem is that the blower never stops after burner shuts off at desired temperature. (Cold air keeps coming endlessly.)
tnakano is offline   Reply With Quote
Old 02-03-2008, 08:25 PM   #4
Member
 
biggles's Avatar
 
Join Date: Jan 2008
Location: Long Island
Posts: 3,630
Rewards Points: 2,000
Default

Carrier furnace keeps running


the stat has the fan set in auto?if your furnace is not that old the fan might come on thru the electronics instead of a switch which brings it on when the furnace heats up...all i can tell you is to shut the main breaker off which will kill all the power to the stat and the furnace maybe it will clear the constant fan signal it is getting...as you said it all cycled...the fan should shut off just as your stat satisfies and the heat section cools down..is your stat digital or with levers that slide left and right to the temps.
biggles is offline   Reply With Quote
Old 02-03-2008, 10:10 PM   #5
Newbie
 
Join Date: Feb 2008
Posts: 2
Rewards Points: 10
Question

Carrier furnace keeps running


breaker, breaker.
Excuse me butting in.. I have an Amstrong Ultra and have the same problem.
The fun runs, but does not appear to be full, if I cut it over to cool the ac works, turn it to heat 75, nothing, but the fan keeps running.
Did the above..
any other thoughts
BW
bwilde is offline   Reply With Quote
Old 02-05-2008, 07:45 PM   #6
Newbie
 
Join Date: Feb 2008
Posts: 4
Rewards Points: 10
Default

Carrier furnace keeps running


Thank you very much for both of you.

First of all, fan switch has been always set at "Auto" position, and the burner has been automatically switched on and off according to the desired temperature, such as suggested 75 degrees. However, as I mentioned before, the blower never stops even after the desired temperature is achieved and burner is stopped.

I tried AC mode, and cooling function kicks in as expected. But the same problem of "unstoppable blower" continues regardless of temperature.

As of right now, the only way to stop the fan is to disconnect the unit.

The unit has a decal saying...
- that this unit is equipped with fusible element,
- that it has to be replaced if it stays open.

Is this "Fusible Element" considered to be the cause ? Is this a type of a job for DIY-er?

Thank you.
tnakano is offline   Reply With Quote
Old 02-06-2008, 08:21 AM   #7
Newbie
 
Join Date: Feb 2008
Posts: 2
Rewards Points: 10
Default

Carrier furnace keeps running


Well we resolved the problem on the Armstrong Ultra.

As I had been doing sheetrock and dust was everywhere, cleaning the filter did not change anything, I shut down the power to the unit and we took out the airflow sensor and cleaned it, while we were at it, we lableled the connectors on the circuit board and pulled out the main blower. It too was jammed with dust.
We cleaned this and put it all back and system is now fine.
bwilde is offline   Reply With Quote
Old 02-09-2008, 10:22 PM   #8
Newbie
 
Join Date: Feb 2008
Posts: 5
Rewards Points: 10
Default

Carrier furnace keeps running


what about the limit switch? did you try replacing it?
wilgo5234 is offline   Reply With Quote
Old 02-13-2008, 01:18 PM   #9
Newbie
 
Join Date: Feb 2008
Posts: 4
Rewards Points: 10
Default

Carrier furnace keeps running


Thank you all for kind comments.

After weeks of trials in vain, I ended up in hiring HVAC professional.
He quickly checked the unit and replaced "Fan/Blower Control Unit". It was 2.5-hour job and he charged $200, including $48.80 for the part.

Once again, thank you very much for all the help.
tnakano is offline   Reply With Quote
Old 03-01-2009, 11:05 PM   #10
Newbie
 
Join Date: Mar 2009
Posts: 1
Rewards Points: 10
Default

Carrier furnace keeps running


I am having the same issue with my Lennox. I am sure that I caused the problem by waiting forever to change the filter. I have changed the filter, cleaned off the blower unit, but still need to clean the airflow sensor.

Where is the airflow sensor? Any help would be appreciated. It is in the low 30s and 20s here in GA and that is way too cold for me!

RW

Advertisement

ryanwhitehurst is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Carrier furnace help code 13 mudtruck HVAC 10 11-23-2013 03:24 PM
furnace blower keeps running dmbrasket@hotmail.com HVAC 7 02-03-2008 04:57 PM
CARRIER 58RAV Furnace Blows Cold Air-No Heat sarosie HVAC 2 12-05-2007 01:00 AM
My Carrier furnace is driving me crazy hifiuser HVAC 6 02-10-2007 10:48 AM




Top of Page | View New Posts