Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 10-19-2009, 12:10 PM   #1
Newbie
 
Join Date: Oct 2009
Posts: 2
Rewards Points: 10
Question

Carrier 58SXA main burner problem...


Hello,

I am having a problem with a 19-year old (circa 1990) Carrier Weathermaker furnace. It is a 58SXA, which, IIRC, was their highest effiency sealed combustion furnace at that time.

It has worked almost without any issues for 19-years. It now has a slight problem that will probably get worse.

Based on my observations when looking through the observation portal, during the heating cycle, everything seems to work properly until the
three main burners ignite. The three main burners light, but will only burn for about for about 5-10 seconds before I can hear the gas valve close and the burners go out. However, within seconds, the three burners will relight and burn again for only a short period of time. As this pattern is repeated, the burn time increases.

Often, the blower motor will start and continue to run while the burners are repeatedly lit and extinguished. Usually, after many cycles, the burners will stay lit. However, in some cases, the "off and on" of the burners will continue past the point where the Tstat calls for heat and the heating cycle ends. In other words, my house is being heated, but it is still worrisome that the furnace will not be capable of delivering the necessary BTUs on really cold days.

I am thinking that there is a main burner flame sensor that may be bad. However, I can only see one group of wires and they appear to only be connected to pilot assembly. Is there a sensor that is part of the pilot assembly that senses the pilot flame and the main burner flame separately or is there a separate main burner flame sensor?

Please let me know if you have any ideas. Thanks.

bfordmn is offline   Reply With Quote
Old 10-19-2009, 06:03 PM   #2
Member
 
Join Date: Dec 2008
Location: West Michigan
Posts: 440
Rewards Points: 250
Default

Carrier 58SXA main burner problem...


I have seen this many times on the sx furnace. That 3 wire assembly is acting up and needs to be replaced. I also recommend getting the secondary heat exchanger inspected for delamination.
Haven't see many that weren't bad. The secondary has a lifetime warranty and you will likely need a Carrier dealer to take care of this.

SKIP4661 is offline   Reply With Quote
Old 10-20-2009, 01:48 PM   #3
Newbie
 
Join Date: Oct 2009
Posts: 2
Rewards Points: 10
Default

Carrier 58SXA main burner problem...


Does this furnace have a separate main burner flame sensor? If not, does it somehow use the pilot flame sensor to determine if the main burners light? Thanks.
bfordmn is offline   Reply With Quote
Old 11-12-2011, 09:09 AM   #4
Newbie
 
Join Date: Nov 2011
Posts: 2
Rewards Points: 10
Default

Carrier 58SXA main burner problem...


I am having the same problem with this same furnace. What is this 3-wire assembly that was offered as the solution, and where do I find it? Did it fix your problem?
regnistep is offline   Reply With Quote
Old 11-12-2011, 09:11 AM   #5
Newbie
 
Join Date: Nov 2011
Posts: 2
Rewards Points: 10
Default

Carrier 58SXA main burner problem...


What is the 3-wire assembly you are talking about to solve this intermittent burn problem on the 58SXA? Where is it located?
regnistep is offline   Reply With Quote
Old 11-12-2011, 09:14 AM   #6
Hvac Pro
 
Join Date: Nov 2008
Location: Winnipeg, Canada
Posts: 9,652
Rewards Points: 2,442
Default

Carrier 58SXA main burner problem...


It sits in front of and slightly below one of the burners. Follow the 1/4 aluminum pilot line from the gas valve to it. DO NOT buy any generic non OEM units as they are made offshore and with NO tolerances and are mostly junk. we had a poster here earlier with lots of problems with them. you want one in a genuine Carrier bag or box.

__________________
"Cut it twice and it is still too short".
yuri is online now   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Heil Furnace Burner Problem timothyr HVAC 79 02-12-2014 07:01 PM
Bryant Furnace main burner goes out after 5 seconds Da_Bears HVAC 8 01-03-2012 01:24 AM
Main water shutoff problem GoodoleBob Plumbing 18 06-16-2011 10:33 PM
carrier 58SX ignition problem typhoon55 HVAC 5 06-08-2005 09:18 PM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.