Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 10-05-2009, 08:34 PM   #1
Newbie
 
Join Date: Oct 2009
Posts: 2
Rewards Points: 10
Question

Carrier 58SS Issues


I have a Carrier 58SS furnace. Installed in 1984. When thermo call for heat, the pilot comes on, the burner kicks on, then kicks off, kicks on again, off again and on again. Usually 3 times. What is the issue here. Is it the flame sensor that is mounted by the pilot flame. If so does anyone have the part number. If not, what could the problem be. Furnace still runs through the cycle just does the on and off thing.

Triumphdude is offline   Reply With Quote
Old 10-05-2009, 08:42 PM   #2
Member
 
GetYourShineBox's Avatar
 
Join Date: Sep 2009
Location: Waterford, MI
Posts: 72
Rewards Points: 75
Default

Carrier 58SS Issues


turn the power off to the furnace and remove the flame sensor and clean it with a light sand cloth,emery cloth or steel wool. since its an old furnace the flame sensor can built up a coating of burn in dust and dirt. re-install it and it should work fine.

GetYourShineBox is offline   Reply With Quote
Old 10-05-2009, 09:34 PM   #3
as seen on tv
 
Join Date: Mar 2009
Location: pa
Posts: 205
Rewards Points: 150
Default

Carrier 58SS Issues


I am not sure but i think that model has a 3 wire pilot burner. If so you can disconnect at plug and test with meter . When the pilot is heated a contact closes valve opens. 1nc 1no
qbert is offline   Reply With Quote
Old 01-18-2010, 08:35 AM   #4
Newbie
 
Join Date: Oct 2009
Posts: 2
Rewards Points: 10
Default

Carrier 58SS Issues


Carrier furnace model 58SS wont start up unless I tap on the pressure sensing switch. My guess is that the switch is sticking and doesnt go into its normal position afteer the heat cycle is complete. Also when it does work, the burner will come on go off two to three times beofre it stays on to complete the cycle. Looking at the schematic, the pressure switch is responsible for keeping the redundant valve in the hold position. Am I close?
Triumphdude is offline   Reply With Quote
Old 01-29-2010, 11:20 AM   #5
Newbie
 
Join Date: Jan 2010
Location: Memphis, TN
Posts: 1
Rewards Points: 10
Default

Carrier 58SS Issues


Symptoms: Thermo calls for heat; inducer fan comes on; pilot lights; approx 60 sec burner lights; burner goes out in 4-6 sec (pilot stays lit); burner relights in approx 6-10 sec; sequence repeats; burner stays lit on relight 7th or 8th time; circulating fan starts approx 60-80 sec; sometimes during heat cycle the burner will go out, and instantly relight (circulating and inducer fans uninterrupted).

I have replaced the 3 wire pilot assembly, the lower control board, the pressure switch, and the inducer fan control board (relay contacts were burnt) and the symptoms persist. I have cut all power to the unit several times to see if timers would reset, to no avail.

In checking voltage to the gas valve, with R&W jumpered to bypass the thermostat, I note 24 VAC to gas valve term #4 and 0 VAC at term #1 (initially); after several seconds (while the inducer fan is running) 24 VAC is applied to term #1 and shortly thereafter the burners light. A few seconds after the burners light voltage disappears from term #1, burner goes out; and the same cycle repeats. After several such cycles 24 VAC does not disappear from term #1, burners light, fan starts and ops okay. Something is interrupting 24 VAC to the #1 term on the gas valve, apparently causing the burners to go out, once lighted -- but, cures itself after several cycles. ...???

Any help will be much appreciated.

Barney, in Memphis
claudebarnhart is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
carrier furnace issues FixItIfICan HVAC 8 11-19-2008 07:09 PM
Carrier rep coming to diagnose a problem Faulknertw HVAC 14 07-17-2008 12:25 AM
Carrier 58RAV LED code 14 issues kcb68 HVAC 2 03-29-2008 03:12 PM
carrier furnace issues sbroways HVAC 2 10-15-2007 09:30 PM
Putting a new Motor in a Carrier Furnace... Wiring issues cbrent HVAC 3 10-08-2007 07:08 PM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.