DIY Chatroom Home Improvement Forum

DIY Chatroom Home Improvement Forum (http://www.diychatroom.com/)
-   HVAC (http://www.diychatroom.com/f17/)
-   -   Carrier 58SS Issues (http://www.diychatroom.com/f17/carrier-58ss-issues-54500/)

Triumphdude 10-05-2009 07:34 PM

Carrier 58SS Issues
 
I have a Carrier 58SS furnace. Installed in 1984. When thermo call for heat, the pilot comes on, the burner kicks on, then kicks off, kicks on again, off again and on again. Usually 3 times. What is the issue here. Is it the flame sensor that is mounted by the pilot flame. If so does anyone have the part number. If not, what could the problem be. Furnace still runs through the cycle just does the on and off thing.

GetYourShineBox 10-05-2009 07:42 PM

turn the power off to the furnace and remove the flame sensor and clean it with a light sand cloth,emery cloth or steel wool. since its an old furnace the flame sensor can built up a coating of burn in dust and dirt. re-install it and it should work fine.

qbert 10-05-2009 08:34 PM

I am not sure but i think that model has a 3 wire pilot burner. If so you can disconnect at plug and test with meter . When the pilot is heated a contact closes valve opens. 1nc 1no

Triumphdude 01-18-2010 07:35 AM

Carrier furnace model 58SS wont start up unless I tap on the pressure sensing switch. My guess is that the switch is sticking and doesnt go into its normal position afteer the heat cycle is complete. Also when it does work, the burner will come on go off two to three times beofre it stays on to complete the cycle. Looking at the schematic, the pressure switch is responsible for keeping the redundant valve in the hold position. Am I close?

claudebarnhart 01-29-2010 10:20 AM

Symptoms: Thermo calls for heat; inducer fan comes on; pilot lights; approx 60 sec burner lights; burner goes out in 4-6 sec (pilot stays lit); burner relights in approx 6-10 sec; sequence repeats; burner stays lit on relight 7th or 8th time; circulating fan starts approx 60-80 sec; sometimes during heat cycle the burner will go out, and instantly relight (circulating and inducer fans uninterrupted).

I have replaced the 3 wire pilot assembly, the lower control board, the pressure switch, and the inducer fan control board (relay contacts were burnt) and the symptoms persist. I have cut all power to the unit several times to see if timers would reset, to no avail.

In checking voltage to the gas valve, with R&W jumpered to bypass the thermostat, I note 24 VAC to gas valve term #4 and 0 VAC at term #1 (initially); after several seconds (while the inducer fan is running) 24 VAC is applied to term #1 and shortly thereafter the burners light. A few seconds after the burners light voltage disappears from term #1, burner goes out; and the same cycle repeats. After several such cycles 24 VAC does not disappear from term #1, burners light, fan starts and ops okay. Something is interrupting 24 VAC to the #1 term on the gas valve, apparently causing the burners to go out, once lighted -- but, cures itself after several cycles. ...???

Any help will be much appreciated.

Barney, in Memphis


All times are GMT -5. The time now is 02:43 AM.


Copyright 2003-2014 Escalate Media LP. All Rights Reserved