Forums | Home Repair | Home Improvement | Painting | Interior Decorating | Remodeling | Landscaping


Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 11-24-2010, 02:46 PM   #1
Newbie
 
Join Date: Nov 2010
Posts: 1
Share |
Default

Carrier 58MXA furnace question


We bought our house a year ago and it is a 5 year old house, 5 year old furnace. The inspector told us that the heater is a champ (a year ago) but today it has been running now for 1 hr 15 min and is pushing cold air. It is 8 degrees outside so I am not sure if it is partially because of the outside temp it is running so long and circulating through the basement and upstairs that it is cool. The heater is in the basement in the laundry room. Please advise if we should call someone or if maybe it is simple like the pilot light is off.
Jen G is offline   Reply With Quote
Old 11-24-2010, 03:32 PM   #2
HVAC / Plumbing
 
Join Date: Feb 2009
Posts: 1,801
Default

Carrier 58MXA furnace question


probably doesn't have a pilot.. Look at the furnace & see if there is fire comming out of the burners. Maybe the fan is just on. We can help if you are able to trouble shoot .. Look at the blower door. there should be a sight glass. look inside for a flashing light. count the flashes
kenmac is offline   Reply With Quote
Old 11-24-2010, 03:33 PM   #3
Member
 
Join Date: Sep 2010
Posts: 449
Default

Carrier 58MXA furnace question


You will have to provide more useful info such as rise in temp (if any) at thermostat. Circulating fan normally won't start unless burners reach a certain temperature.

Verify that burners are lit. Put your hand on plenum near furnace. Advise if hot or cold.
diyorpay is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gas furnace exhaust vent question nowell HVAC 7 01-30-2012 08:31 AM
Pump for a furnace question! PLEASE HELP! . VERY COLD LOL dvandam HVAC 9 12-12-2009 07:48 AM
Carrier 58MCA Furnace No Heat (Error 33) zerafah49 HVAC 1 12-10-2008 07:32 PM
Problems with new furnace..Overheating, having to reset. Furnace too big? Tommy2 HVAC 41 12-01-2008 01:55 PM
CARRIER 58RAV Furnace Blows Cold Air-No Heat sarosie HVAC 2 12-05-2007 12:00 AM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.