Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 01-26-2008, 09:56 AM   #1
Newbie
 
Join Date: Jan 2008
Posts: 1
Rewards Points: 10
Post

Carrier 58MXA Code 31 Problem


I Have a Carrier Weathermaker 58MXA installed in 1996. I have an intermittent failure problem (Code 31) that appears to occur during cold weather, night time mostly. I have replaced the pressure switch - the problem is still recurring. I have seen several threads that suggest it may require cleaning of the secondary heat exchanger. Was wondering if anyone had information on this procedure.

I am also aware of the class action suite.

MikeZ is offline   Reply With Quote
Old 01-27-2008, 08:22 PM   #2
Member
 
Join Date: Apr 2007
Location: Sringfield, Oh
Posts: 111
Rewards Points: 75
Default

Carrier 58MXA Code 31 Problem


Try cleaning the trap and making sure your drains are clean. Other things to check is the intake and exhaust pipes. They should also be clear and slope back to the furnace with no sags. Pressure switches don't usually go bad. Normally, the drains and traps are plugged up.

sgthvac is offline   Reply With Quote
Old 01-28-2008, 05:55 AM   #3
Union HVAC Tech.
 
Join Date: May 2007
Location: New Jersey
Posts: 607
Rewards Points: 500
Default

Carrier 58MXA Code 31 Problem


Yeah drains and traps get clogged but pressure switch diaphrams go bad all the time. So where you get they don't go bad must be from another planet, on earth nothing lasts forever.
bigMikeB is offline   Reply With Quote
Old 01-28-2008, 06:10 AM   #4
Member
 
Join Date: Apr 2007
Location: Sringfield, Oh
Posts: 111
Rewards Points: 75
Default

Carrier 58MXA Code 31 Problem


bigMikeB, You are right about parts failing; they do fail, but MikeZ should have cleaned the trap and drains first. Personallly, I do everything I can before I change a part.
sgthvac is offline   Reply With Quote
Old 01-28-2008, 06:17 AM   #5
Union HVAC Tech.
 
Join Date: May 2007
Location: New Jersey
Posts: 607
Rewards Points: 500
Default

Carrier 58MXA Code 31 Problem


Me too. It needs to be checked with a meter which is something that gets over looked here way too often. Too many guys here just like to guess and swap parts.
bigMikeB is offline   Reply With Quote
Old 10-25-2009, 09:33 PM   #6
Newbie
 
Join Date: Oct 2009
Posts: 1
Rewards Points: 10
Default

Carrier 58MXA Code 31 Problem


after 12 years of flawless operation our 58MXA started to malfunction last year. at that time no codes.. thought there was a problem with the thermostat so replaced it. seemed better, but really wasn't , kept house warm so no worries. would attempt to start numerous times and shut down.
This year same thing only worse, so I found the diagnostic flow charts on-line and started doing some testing.
This year it did set code 3-1, checked out everything associated with that code and all was good no part failure.
Started to wiggle the wires to the circuit board and could get it to come and go, thought it was a loose wire, so I pulled the circuit board out to inspect the connections. There are two resistors soldered onto the circuit board, one had a cracked solder joint (cold) which was causing an intermitant connection on the processor board. I resoldered the cold joint and inspected all other connections, It has worked flawlessly since the repair. See attached photos. first photo(2745) shows 330 ohm resistor with bad joint on upper left connection.
Attached Thumbnails
Carrier 58MXA  Code 31 Problem-img_2745.jpg   Carrier 58MXA  Code 31 Problem-img_2750.jpg   Carrier 58MXA  Code 31 Problem-img_2746.jpg  

Last edited by jsspoole; 10-25-2009 at 09:35 PM. Reason: spelling
jsspoole is offline   Reply With Quote
Old 01-11-2010, 06:14 PM   #7
Newbie
 
Join Date: Jan 2010
Location: Nashville, tn
Posts: 1
Rewards Points: 10
Default

Carrier 58MXA Code 31 Problem


I have the same issue that MikeZ had - intermittent operation with the inducer motor coming on after manual reset. I disconnected the power lead from the inducer motor going to the circuit board and wired it directly to a switched 110 power source. After manually resetting the furnace, I waited for the blower to go thru its 90 sec. test and then switched on the inducer motor. Worked every time. Pressure switch would engage then the ignitor would come on then the gas then the blower motor.

Pulled the board to inspect and saw the discoloration around the same resitors as MikeZ but did not do anything then replaced the board. I hooked everything back up properly including the inducer motor and everything works normally. I'm going to let it run until it fails again which I'll then resolder the resistors. I think that pulling the board and putting it back re-established the connection
stu2 is offline   Reply With Quote
Old 01-12-2010, 02:00 AM   #8
Member
 
Join Date: Nov 2008
Location: palm coast fl
Posts: 588
Rewards Points: 500
Default

Carrier 58MXA Code 31 Problem


thanks to jsspoole for the usefull info, as a tech most of us are taught to just throw those boards away when they fail. guess its because we have 15 other places to be but knowing that a quick fix like that would be useful on a latenight service and no replacement board on the truck. bravo
kennzz05 is offline   Reply With Quote
Old 01-12-2010, 07:32 AM   #9
Member
 
Join Date: Oct 2009
Location: Nebraska
Posts: 2,362
Rewards Points: 1,000
Default

Carrier 58MXA Code 31 Problem


Quote:
Originally Posted by kennzz05 View Post
thanks to jsspoole for the usefull info, as a tech most of us are taught to just throw those boards away when they fail. guess its because we have 15 other places to be but knowing that a quick fix like that would be useful on a latenight service and no replacement board on the truck. bravo
Not a good idea for a tech to solder a furnace board kennzzo5. Should the flame proving feature fail and cause a fire your company is liable. I'll touch up defrost boards and such but not a furnace board.

Marty S. is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
carrier furnace problem dqdave1 HVAC 14 02-06-2010 05:57 PM
Carrier 58MXA pressure/vacuum problem gshock HVAC 8 01-17-2008 07:13 PM
code 31 Carrier 58MXA Mr. Break It HVAC 1 01-02-2008 11:24 AM
Carrier code 31 on 58MXA (WeatherMaker 9000?) SteveAnnArbor HVAC 7 11-05-2007 07:53 PM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.