Forums | Home Repair | Home Improvement | Painting | Interior Decorating | Remodeling | Landscaping


Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 08-01-2010, 03:26 PM   #1
Newbie
 
Join Date: Aug 2010
Posts: 2
Share |
Default

carrier 58gs problems after icm271 replacement


Hello:
I have an old carrier 58gs075-3.
After months without use the A/C was turned on.
The unit appeared to function normally and cool the house,
but the internal fan (air handler?) stayed on after the compressor
shut off. Had to unplug unit to get it to turn off.

Research showed that the CFR (fan relay) was probably stuck,
so I replaced the control board with the icm271. All seemed to
work fine for a few minutes. Plug in unit and no fan. Turn on
thermostat and fan turned on and compressor kicked on and
air came out. goody problem seemed to be solved.

Then a click of somekind and the compressor turned off and
the int. fan kept going, but no cool air and no compressor to
cool. Worse than when I started.

Tests done:
limit switch is closed
fuseable link is closed
fuse on icm271 is closed

Any other tests I can perform to see if it is the transformer now
or is the outside fan/compressor failing now?

thanks for any help

dank1j is offline   Reply With Quote
Old 08-01-2010, 04:28 PM   #2
Newbie
 
Join Date: Aug 2010
Posts: 2
Default

carrier 58gs problems after icm271 replacement


follow-up.
tested voltage across R and C -- nothing?
across sec-1 and sec2 I get 30 VAC which is high

gonna test that fuse again to see if that might be gone
Anything else to test?
Should I get a new transformer if 30VAC is too high?

thanks again.

dank1j is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ignitor sparks through complete cycle. Carrier 58GS slick-rides HVAC 26 12-24-2009 09:08 AM
Carrier AC problems Snookered HVAC 1 09-23-2009 09:28 PM
Carrier furnace problems BigK75 HVAC 1 07-30-2009 05:16 PM
This may help someone with carrier ignition problems AweMan HVAC 15 02-09-2009 01:20 PM
Carrier furnace problems thall860 HVAC 4 10-27-2008 07:29 AM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.