Carrier 58GS Blower Stoped Working - HVAC - DIY Chatroom Home Improvement Forum


Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Display Modes
Old 04-18-2013, 04:47 PM   #1
Newbie
 
Join Date: Apr 2013
Posts: 8
Rewards Points: 10
Default

Carrier 58GS blower stoped working


Hello, I have a 1990 Carrier Model 58GP,GS
Carrier
model 58GS100-3
series 301
Blower 109
1/2 hp
I could smell an electrical burn and the motor has stopped blowing.
I cant figure out how to get the lower panel off. The upper on with the vents lifted out easy.
Anyone know a model # of the blower and how to open the panel?
Thanks for taking time to read this.

Advertisement

Trops357 is offline   Reply With Quote
Old 04-18-2013, 06:08 PM   #2
I'm Your Huckleberry
 
Join Date: Mar 2011
Posts: 5,884
Rewards Points: 2,270
Default

Carrier 58GS blower stoped working


post a picture of the panel, the entire front of the unit. we'll tell you how to remove it once we can see it like you see it.

it's going to be the blower motor or the capacitor, why the blower is not running.

Advertisement

__________________
Thanks.
Doc Holliday is offline   Reply With Quote
Old 04-18-2013, 09:04 PM   #3
Newbie
 
Join Date: Apr 2013
Posts: 8
Rewards Points: 10
Default

Carrier 58GS blower stoped working


Quote:
Originally Posted by Doc Holliday View Post
post a picture of the panel, the entire front of the unit. we'll tell you how to remove it once we can see it like you see it.

it's going to be the blower motor or the capacitor, why the blower is not running.

Thanks for such a prompt reply.
Here are some pics.

http://i381.photobucket.com/albums/o...Untitled-2.gif

http://i381.photobucket.com/albums/o...Untitled-3.gif

http://i381.photobucket.com/albums/o...s/IMAG0021.jpg

http://i381.photobucket.com/albums/o...s/IMAG0022.jpg

http://i381.photobucket.com/albums/o...s/IMAG0023.jpg

http://i381.photobucket.com/albums/o...s/IMAG0024.jpg

http://i381.photobucket.com/albums/o...IMAG0025-1.jpg

http://i381.photobucket.com/albums/o...s/IMAG0026.jpg
Trops357 is offline   Reply With Quote
Old 04-18-2013, 09:37 PM   #4
Member
 
Join Date: Oct 2012
Posts: 282
Rewards Points: 266
Default

Carrier 58GS blower stoped working


The bottom panel just slides up. It hooks over the shelf on the inside top. If it hasn't been open in a few years you might need to use something slid into the bottom slit and pry up.
old_squid is offline   Reply With Quote
Old 04-18-2013, 09:48 PM   #5
Roofmaster
 
Join Date: Oct 2012
Location: Maryland
Posts: 3,669
Rewards Points: 2,096
Default

Carrier 58GS blower stoped working


Yeah, you just slide it up and out toward you. Remove the two screws that hold the board mounting bracket in then the two 5/16" HWH screws that hold the motor in and it slides right out on its rails.

Check www.pexsupply.com for a new motor
__________________
" A lot of men build things, and a lot of things fall down "

jagans is offline   Reply With Quote
Old 04-20-2013, 10:38 AM   #6
Newbie
 
Join Date: Apr 2013
Posts: 8
Rewards Points: 10
Default

Carrier 58GS blower stoped working


Thank you so much for the replies and links.
It came off no problem with just a little preasure using
a screwdriver at the bottom.

Here is a pic.




I guess I need to remove the box to get the blower out.
Seems to be enuf wire to just place it out of the way
while I pull out the blower.
Breaker is OFF.

Time to get on the floor and get a little dirty!
Trops357 is offline   Reply With Quote
Old 04-20-2013, 11:17 AM   #7
I'm Your Huckleberry
 
Join Date: Mar 2011
Posts: 5,884
Rewards Points: 2,270
Default

Carrier 58GS blower stoped working


it's childsplay in all honesty. do you have a meter to test voltage? perhaps one that tests mfd (microfarads)?
__________________
Thanks.
Doc Holliday is offline   Reply With Quote
Old 04-20-2013, 12:02 PM   #8
Newbie
 
Join Date: Apr 2013
Posts: 8
Rewards Points: 10
Default

Carrier 58GS blower stoped working


I loosened the set screw on the shaft of the motor.
I removed the 3 bolts holding the motor to housing.
Bushings are in good condition.
Then as I moved it, I heard a "slosh sound".
Yeah, it had water in it.
The water was clean.
It was only the second time this season I had used the A/C.
The 1st time some water leaked from the Left Rear corner, about
2.5 ft. It stopped running to the floor after it reached about 2.5 feet
and the A/C worked fine, and blower was still running.

The 2nd time , which was the day I first posted here, it leaked about
4 in. at the same corner. Then my wife smelled something
electrical burn. I went to basement and the motor/fan had a different
sound, sounded slower and labored. The A/C cut off, and when I tried
to restart the blower never came back on.

Any ideas on how to look for blockages that might cause water to build
up inside the furnace?
Inside of the blower is not rusted or anything like that. I do see some
rust on the back inside wall of the furnace.







Trops357 is offline   Reply With Quote
Old 04-20-2013, 12:07 PM   #9
Newbie
 
Join Date: Apr 2013
Posts: 8
Rewards Points: 10
Default

Carrier 58GS blower stoped working


Quote:
Originally Posted by Doc Holliday View Post
it's childsplay in all honesty. do you have a meter to test voltage? perhaps one that tests mfd (microfarads)?
yes, I have meter. I used to repair 3 phase motors. Check for continuity,
short to the housing, bearings, etc.

They did not have capacitors or circuitry for variable speeds.
Can you give me some advice on testing the motor and/or
the capacitor.
Trops357 is offline   Reply With Quote
Old 04-20-2013, 01:10 PM   #10
Newbie
 
Join Date: Apr 2013
Posts: 8
Rewards Points: 10
Default

Carrier 58GS blower stoped working


Quote:
Originally Posted by Doc Holliday View Post
it's childsplay in all honesty. do you have a meter to test voltage? perhaps one that tests mfd (microfarads)?
My meter, try not to laugh



I got 2 sets of Wiggly's too
Trops357 is offline   Reply With Quote
Old 04-21-2013, 07:36 PM   #11
Member
 
Join Date: Jun 2012
Location: Missouri
Posts: 99
Rewards Points: 75
Default

Carrier 58GS blower stoped working


That meter looks like it doesn't have a setting for measuring capacitance (mfd or microfarads)

Also, it could be possible that the control circuitry (controller or relay) burned. I've witnessed a few Control Board's burn on older Carrier furnaces.

Just trying to help. For the record, I'm not a technician

Last edited by ModelAFan; 04-21-2013 at 07:40 PM.
ModelAFan is offline   Reply With Quote
Old 04-21-2013, 08:12 PM   #12
Newbie
 
Join Date: Apr 2013
Posts: 8
Rewards Points: 10
Default

Carrier 58GS blower stoped working


Quote:
Originally Posted by ModelAFan View Post
That meter looks like it doesn't have a setting for measuring capacitance (mfd or microfarads)

Also, it could be possible that the control circuitry (controller or relay) burned. I've witnessed a few Control Board's burn on older Carrier furnaces.

Just trying to help. For the record, I'm not a technician
Thank you
Trops357 is offline   Reply With Quote
Old 04-21-2013, 09:08 PM   #13
Member
 
Join Date: Oct 2011
Location: pa
Posts: 4,646
Rewards Points: 2,606
Default

Carrier 58GS blower stoped working


Quote:
Originally Posted by Trops357 View Post
Thank you
you can also test a capacitor with a multimeter....set for olms hook to cap them set to dc volts meter will start to discharge through meter showing good capacitor..ben sr
ben's plumbing is online now   Reply With Quote
Old 04-22-2013, 09:30 AM   #14
Newbie
 
Join Date: Apr 2013
Posts: 8
Rewards Points: 10
Default

Carrier 58GS blower stoped working


Quote:
Originally Posted by ben's plumbing View Post
you can also test a capacitor with a multimeter....set for olms hook to cap them set to dc volts meter will start to discharge through meter showing good capacitor..ben sr
Thank you !

Advertisement

Trops357 is offline   Reply With Quote
The Following User Says Thank You to Trops357 For This Useful Post:
ben's plumbing (04-23-2013)
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Carrier 58MVP -blower continues to run realprop HVAC 15 01-25-2012 12:37 AM
Carrier 9200 Weathermaker not working markwells HVAC 1 09-27-2011 08:22 PM
Carrier 58MXA Wiring Blower Switch 63012753 HVAC 0 10-06-2009 10:09 PM
HELP! Carrier Weathermaker Infinity Not Working! MaxPierre HVAC 27 01-19-2009 07:30 PM
RUUD furnace not working blower runs ddeatrick99@hotmail.com HVAC 2 01-16-2008 10:55 PM




Top of Page | View New Posts