Carrier 58 PAV LED Blinking And No Heat - HVAC - DIY Chatroom Home Improvement Forum


Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Display Modes
Old 09-27-2010, 03:57 PM   #1
Newbie
 
Join Date: Nov 2009
Posts: 3
Rewards Points: 10
Default

Carrier 58 PAV LED blinking and no heat


Hello Forum thank in advance for any help I have a Carrier 58 PAV Upflow and today I turned on the heat for he first time this season and the blower works but no heat. The unit worked last winter and the AC still works fine.

I checked the control board and receives continuous blinking red light. The hot surface ignitor is clean and I replaced it last year, the flame sensor is clean and I replace the filter each month. Any help would be greatly appreciated. Thanks

Bill

Advertisement

billytjr is offline   Reply With Quote
Old 09-27-2010, 04:08 PM   #2
Member
 
hvaclover's Avatar
 
Join Date: Oct 2008
Location: Suburbs of Detroit Mi
Posts: 3,704
Rewards Points: 2,000
Default

Carrier 58 PAV LED blinking and no heat


Sound like an open limit or a bad board.

Advertisement

__________________
Just slow, not stupid.
hvaclover is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Draft Inducer Blower Not Blowing- LED Blinking 3 Times rust101 HVAC 10 04-09-2013 09:44 PM
Carrier 58PAV Error code 14 Hermmona HVAC 9 01-05-2012 11:42 AM
Amana roll out switch light blinking butter99 HVAC 2 04-02-2010 11:19 PM
Heat and Condenser running at same time emmark22 HVAC 2 01-12-2010 01:28 AM
Moved thermostat - Now no heat. Bernan HVAC 2 11-15-2009 01:16 PM




Top of Page | View New Posts