Auxillary Heat Problem - HVAC - DIY Chatroom Home Improvement Forum


Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Display Modes
Old 02-27-2013, 08:07 PM   #1
Newbie
 
Join Date: Feb 2013
Posts: 3
Rewards Points: 10
Default

Auxillary Heat Problem


I have an Armstrong Heat Pump HVAC unit with electrical strips for auxilliary heat. When my thermostat engages the heat pump in the heat setting, (I also have an emergency heat setting but this is not what is on.), my heat pump comes on along with the fan but the heat strips come on as well. When the desired temp is reached on the thermostat the heat pump goes off but the heat strips and fan remain on. You can set the thermostat to off but this does nothing the only way to shut the strips and fan off is to turn off the breaker in electrical panel. Any ideas would be greatly appreciated.

Advertisement

kevinm2512 is offline   Reply With Quote
Old 02-27-2013, 08:44 PM   #2
An old Tradesmen
 
Join Date: Oct 2008
Location: PA
Posts: 26,548
Rewards Points: 4,734
Default

Auxillary Heat Problem


Heat sequencer stuck closed. Needs to be replaced. Or a short in the wiring.

Advertisement

beenthere is offline   Reply With Quote
Old 02-28-2013, 09:55 PM   #3
Newbie
 
Join Date: Feb 2013
Posts: 3
Rewards Points: 10
Default

Auxillary Heat Problem


I replaced the sequencer and get the same results
kevinm2512 is offline   Reply With Quote
Old 02-28-2013, 09:58 PM   #4
An old Tradesmen
 
Join Date: Oct 2008
Location: PA
Posts: 26,548
Rewards Points: 4,734
Default

Auxillary Heat Problem


Trace out wires, look for a short.
beenthere is offline   Reply With Quote
Old 02-28-2013, 10:01 PM   #5
Newbie
 
Join Date: Feb 2013
Posts: 3
Rewards Points: 10
Default

Auxillary Heat Problem


Any chance it could be the fan control board.
kevinm2512 is offline   Reply With Quote
Old 03-01-2013, 05:10 AM   #6
An old Tradesmen
 
Join Date: Oct 2008
Location: PA
Posts: 26,548
Rewards Points: 4,734
Default

Auxillary Heat Problem


Possible. But you should use a meter to check if the board is getting a heat call on the W terminal or not, before just changing out the board.
beenthere is offline   Reply With Quote
Old 03-01-2013, 05:10 AM   #7
An old Tradesmen
 
Join Date: Oct 2008
Location: PA
Posts: 26,548
Rewards Points: 4,734
Default

Auxillary Heat Problem


Possible. But you should use a meter to check if the board is getting a heat call on the W terminal or not, before just changing out the board.

Advertisement

beenthere is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
heat pump freezing problem av-geek HVAC 8 02-02-2012 08:16 PM
Trane XR11 heat pump problem with compressor not always starting right away.. mikebdub HVAC 11 01-29-2011 06:38 AM
Governments Renewable Heat Incentive SMurray Green Home Improvement 1 10-24-2010 09:30 AM
Urgent! House Cold, NO heat, pilot lit (Lennox) ThatGuy23 HVAC 15 02-05-2009 10:11 PM
HUGE Icicle problem & Heat Loss zaibas Roofing/Siding 5 02-01-2009 04:33 PM




Top of Page | View New Posts