DIY Chatroom Home Improvement Forum

DIY Chatroom Home Improvement Forum (http://www.diychatroom.com/)
-   HVAC (http://www.diychatroom.com/f17/)
-   -   Armstrong package air conditioner furnace issue (http://www.diychatroom.com/f17/armstrong-package-air-conditioner-furnace-issue-89577/)

cptkrk 12-14-2010 06:53 AM

Armstrong package air conditioner furnace issue
 
I have a Armstrong package unit that is having some furnace issues. The unit appears to be shutting down after about 20-30 minutes of operation. The precombustion blower comes on, and the burners light, but after a short while, the burners go out and the system cycles again. The furnace will run for about 20 minutes then will shutdown and will not restart unless the power is removed\restored to the unit.

I have looked at the control board and it appears to have some discoloration around some of the resistors\capacitors. The blower appears to be working but the airflow is not as strong as it used to be.

The unit is approximately 7-8 years old.

bob22 12-14-2010 08:15 AM

have you changed out the air filters? If they are clogged or other obstructions to air flow you could have a shut down. Perhaps flame sensor is dirty?

cptkrk 12-14-2010 08:28 AM

The filter has been replaced recently. I even went as far as removing the filter temporarily to see if the airflow improved and it did but not drastically and the furnace still shutdown after about 30 minutes.

Could the issue possibly be that I lost a speed in the blower? I have not cleaned the furnace other than the usual coils.


All times are GMT -5. The time now is 11:31 PM.


Copyright 2003-2014 Escalate Media LP. All Rights Reserved