Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 10-27-2013, 10:11 PM   #1
Member
 
Dave Sal's Avatar
 
Join Date: Dec 2012
Location: Chicago, Illinois
Posts: 291
Rewards Points: 258
Default

Aprilaire 600M humidifier not working


Hey guys,

I have a three year old Aprilaire 600M humidifier mounted on the cold air return. The water supply is connected to the hot water line of the water heater with a saddle valve. Last year at this time the humidifier wasn't working. Had the HVAC guy come out and he found that the saddle valve was clogged with white particles, apparently from the water heater. He changed it and it worked perfectly for the rest of the heating season. I just turned it on again for the new heating season and it worked for the first couple of days. Today I noticed it was getting a bit drier than usual and checked the humidifier and it's not working. I'm guessing that the saddle valve is clogged again. My question is what would be the best way to connect the water supply to the hot water line. Saddle valves seem cheap and prone to fail or leak. There's got to be a better way. Any suggestions?
Attached Thumbnails
Aprilaire 600M humidifier not working-img_2231.jpg  

Dave Sal is offline   Reply With Quote
Old 10-28-2013, 04:36 AM   #2
An old Tradesmen
 
Join Date: Oct 2008
Location: PA
Posts: 25,497
Rewards Points: 2,678
Default

Aprilaire 600M humidifier not working


Tee off hot water line with a 3/8" line, install valve, then reduce to 1/4" for water heater.

__________________
When posting in certain forums, knowing your location will help others give better feedback/advice/solutions to your questions.
beenthere is offline   Reply With Quote
Old 10-28-2013, 05:28 AM   #3
Member
 
Join Date: Oct 2011
Location: pa
Posts: 4,429
Rewards Points: 2,172
Default

Aprilaire 600M humidifier not working


yep cut into waterline with a tee .we use 5/8 od x 3/8 od compression valve then use 3/8 x 1/4 reducer for humidifier....ben sr
ben's plumbing is online now   Reply With Quote
Old 10-28-2013, 08:40 AM   #4
Member
 
Dave Sal's Avatar
 
Join Date: Dec 2012
Location: Chicago, Illinois
Posts: 291
Rewards Points: 258
Default

Aprilaire 600M humidifier not working


Thanks for the replies guys. That sounds like the way it should have been done in the first place.
Dave Sal is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Armstrong Furnace and Aprilaire humidifier wont shut off! HELP! scott0949 HVAC 8 12-09-2010 06:30 PM
Air Exchanger and Humidifier Zombify HVAC 0 05-11-2010 11:38 AM
Aprilaire 700A Humidifier - Automatic control question feign3 HVAC 1 12-11-2007 04:31 PM
Aprilaire Humidifier ffgus HVAC 4 02-05-2007 04:04 PM
Aprilaire 700 to Carrier product # FK4BNF003000AAA mag-md HVAC 10 12-17-2006 07:49 PM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.