Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 12-08-2005, 09:00 PM   #1
Newbie
 
Join Date: Dec 2005
Posts: 1
Rewards Points: 10
Exclamation

Amer. Std. Freedom 80 blower/fan died


A few months ago our American Standard Freedom 80 started making weird noises, and then the fan started making scraping noises when it was winding down. Eventually it went out and now there's a faint burning smell. The system doesn't throw a code on the LED, but there is NO intake/exhaust because the fan is dead. The burners come on like everything is normal, too. The blower still makes an electrical hum, though. With the unit turned off, I reached in there and tried to feel if anything was obstructing the turbine, but it make screetching noises when I turned it - so it's definitely gone. Does anyone know where I can buy the blower unit, or if I can even DIY something like this? I'd hate to cut time out of my day and get ripped off.

I'm thinking I need part 1 of this diagram below. I recall looking at a label on mine that said it was a GE part.

digitalbow is offline   Reply With Quote
Old 01-07-2006, 10:50 AM   #2
weinstall.ca
 
Join Date: Jan 2006
Location: mississauga Ontario
Posts: 36
Rewards Points: 25
Post

Amer. Std. Freedom 80 blower/fan died


You better be very careful when working with any magnetic motor. when you turn a magnetic motor it will feel like it is seized but this is only because of the magnetics holding the shaft.
I doubt if it is the motor , most likely magnets or control module

weinstall.ca

allan is offline   Reply With Quote
Old 01-07-2006, 10:51 AM   #3
weinstall.ca
 
Join Date: Jan 2006
Location: mississauga Ontario
Posts: 36
Rewards Points: 25
Default

Amer. Std. Freedom 80 blower/fan died


Quote:
Originally Posted by allan
You better be very careful when working with any magnetic motor. when you turn a magnetic motor it will feel like it is seized but this is only because of the magnetics holding the shaft.
I doubt if it is the motor , most likely magnets or control module

weinstall.ca
How can i fix it if i dont know how it works
allan is offline   Reply With Quote
Old 10-01-2012, 01:58 PM   #4
Newbie
 
Join Date: Oct 2012
Posts: 1
Rewards Points: 10
Default

Amer. Std. Freedom 80 blower/fan died


Bumping to help with an answer.
This just happened to me in 2012.

My flue gas vent fan was making the scrapping noises as well as described by the OP. WE took a little vacation and when we got home the vent was siezed. The electric motor EXTREMELY hot and the furnace still working normally. I'm surprised there is no shut down on flue has draft.

Anyways, I took the fan off (5 screws on the blower mount and 3 on the exhaust) and took a look. I was able to spin the fan and see a small wobble. It looks like the fan slowly builds up oscillation and begins to rub on internal bolt heads inside the chamber. I was able to bend the fan myself just by pushing down on the blades to stop the rubbing and allow unrestricted spinning.

The fiberglass gasket got messed up on the removal, but I reinstalled everything and it all works normally.

This is a temp fix to get heat back into our home until a vent fan and gasket can be purchased.
Klautt is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off





Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.