30 Year Old Luxaire Furnace ( I Know Time To Get A New One ) - HVAC - DIY Chatroom Home Improvement Forum


Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Display Modes
Old 01-15-2011, 01:33 AM   #1
Newbie
 
Join Date: Jan 2011
Posts: 1
Rewards Points: 10
Default

30 Year Old Luxaire Furnace ( i know time to get a new one )


The Burners Wont Stay On They Keep Shutting Down and turning back on as it does this i hear a click just as it comes on and other times it wont come on at all just the pilot is lit ,,, there is an orange wire in rubber that i have moved and it would work for sometime but now it doesn't seam to have any affect like it did before....
please help im in ne ohio and 2 kids i cant get a new one yet no money and calling the repair man is expencive had him here 3 times in the last 2 months for one problem or another with this and now it is friday weekend rates i cant aford it

Advertisement

dd0179 is offline   Reply With Quote
Old 01-15-2011, 09:16 AM   #2
Member
 
Join Date: Sep 2010
Posts: 453
Rewards Points: 252
Default

30 Year Old Luxaire Furnace ( i know time to get a new one )


Sounds like flame sensor. It's by one of burners. Clean with steel wool, emery cloth or fine sandpaper. Consider replacing if that works. Part is not so expensive.

Advertisement

diyorpay is offline   Reply With Quote
Old 01-15-2011, 12:37 PM   #3
Newbie
 
Join Date: Jan 2011
Location: Eau Claire,Wi
Posts: 3
Rewards Points: 10
Default

30 Year Old Luxaire Furnace ( i know time to get a new one )


The orange wire in rubber sounds like your spark ignition wire, so you must have electronic ignition on the furnace. Which means when there is a call for heat the pilot sparks and lights, correct? So if your pilot comes on but not the main burners the pilot assembly must not be sensing flame. Does the pilot assembly have like a metal rod? If so try cleaning it with sandpaper.
GhostRider96 is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with 4 year old furnace... cutthroat HVAC 5 12-25-2010 09:49 PM
Luxaire Furnace Won't Fire ChuckAnderson HVAC 14 12-07-2010 10:19 PM
Luxaire Gas furnace bolesrs HVAC 5 12-06-2009 09:33 PM
Luxaire Furnace Overtemping! MIKE77 HVAC 6 01-25-2009 09:55 PM
Oil furnace does not fire up sbhavinm HVAC 5 01-17-2009 08:06 AM




Top of Page | View New Posts