DIY Chatroom Home Improvement Forum

DIY Chatroom Home Improvement Forum (http://www.diychatroom.com/)
-   Landscaping & Lawn Care (http://www.diychatroom.com/f16/)
-   -   Begonia Mold (http://www.diychatroom.com/f16/begonia-mold-72397/)

Otis Gudlyfe 05-30-2010 10:51 AM

Begonia Mold
 
2 Attachment(s)
Last year we planted an azalea here and it died. This year we planted some begonias and they seem to have developed a fungus of some type.
Anybody out there able to identify it and recommend a treatment?

downunder 05-30-2010 11:54 AM

If two completely different plants died/grow poorly in the same spot, I'm thinking a site problem. How wet does it stay there? It looks like it could be edema, or overwatering. Can't tell if that's mold or just dark foliage. Does it wipe off? How long after planting before the azalea died? In other words, had it gotten established, grow well for several years, then die or did you plant it and six months later it was dead?

Otis Gudlyfe 05-30-2010 01:52 PM

I considered that it may be a site problem. The site is not wet and is slightly higher than the surrounding areas.
The azalea started declining in about 3 months and about half of it was necrotic by the end of the growing season. The begonias were planted about 3 weeks ago. There is nothing on them that wipes off. I'm also thinking that what we are seeing may be the result of some kind of toxin in the soil.

downunder 05-31-2010 01:42 PM

I would dig the whole plant- roots, soil, and all and take to your local university extension office.


All times are GMT -5. The time now is 04:25 AM.