DIY Chatroom Home Improvement Forum

DIY Chatroom Home Improvement Forum (http://www.diychatroom.com/)
-   Tractors & Mowers (http://www.diychatroom.com/f106/)
-   -   pressure washer (http://www.diychatroom.com/f106/pressure-washer-146192/)

Barry J 06-06-2012 01:53 PM

pressure washer
 
1 Attachment(s)
I have a Craftsman pressure washer 6.75 HP 2500 PSI 2.2 GPM.
Last year the washer stopped working, I figured It was a little over heated but, this year I figured I would attempt to start it up to see what was wrong with it, but could not hook up the hi pressure hose to the aluminum outlet from the pump. There was a black plastic piece in the way.
On the diagragm from the owners manual it does not say anything about a black piece.
It looks like a vale of some sort, before I order another outlet and replace it, could this piece be from the pump and blown thru the outlet to the end???
I do have a pic of it but will attempt to attach it
Thanks
Barry



danpik 06-09-2012 08:49 PM

It does look like it may be from further upstream in the output side of the pump. It has been a while since I have had that type of pump apart so I am not sure. That tube should not have anything in it though. It is just an extension tube to get the discharge out to the edge of the washer body.

If you have the 9 digit sears number you can look up the washer & parts on their web site. There usually is some exploded views showing the parts inside. Most times I have to replace bad O-rings in washers when people run them dry


All times are GMT -5. The time now is 08:55 AM.